I have an MSi GE70 Laptop (Graphics: nvidia GeForce GT650M). At first I couldn't boot nor install. After adding 'nomodeset' in Grub I was able to start the installation. `Try Ubuntu`` just gave me a blank screen.

I installed a dualboot with Ubuntu 13.10 and Windows 8.1, UEFI, secure boot off (UEFI with CSM).

After the installation was a success, the computer boots straight into Windows. I knew this could happen and need to run boot-repair from the live-CD. Unfortunately I can't find a way to do this from CLI, since I get a blank screen in X I cannot use it's GUI.

I tried installing nvidia-current when booted with the live-CD, restarting lightdm (/etc/init.d/lightdm stop/start). No luck.

Trying to diagnose the problem this are the things I found: /var/log/lightdm/x-0.log ends like this:

(EE) Fatal server error:
(EE) no screens found
(EE) Please consult the The X.org Foundation support at http://wiki.x.org for help
(EE) Please also chech the log file at /var/log/Xorg.0.log for additional information.
(EE) Server terminated with error (1). Closing log file.

Looking at /var/log/xorg.0.log I noticed:

[  1867.351] (II) VESA(0): initializing int10
[  1867.351] (EE) VESA(0): V_BIOS address 0x0 out of range
[  1867.351] (II) UnloadModule: "vesa"
[  1867.351] (II) UnloadSubModule: "int10"
[  1867.351] (II) Unloading "int10"
[  1867.351] (II) UnloadSubModule: "vbe"
[  1867.351] (II) Unloading "vbe"
[  1867.351] (EE) Screen(s) found, but none have a usable configuration.
[  1867.351] (EE) Fatal server error
[  1867.351] (EE) no screens found
[  1867.351] (EE) Please consult the The X.org Foundation support at http://wiki.x.org for help.
[  1867.351] (EE) Please also chech the log file at /var/log/Xorg.0.log for additional information.
[  1867.351] (EE)
[  1867.351] (EE) Server terminated with error (1). Closing log file.

So I am trying to run Boot-repair, but I'm stuck because I can't get the GUI working with the live-CD. I've added nomodeset, tried xforcevesa.

Can anybody help me with either Boot-repair from CLI or graphics in live-CD? For me it's weird that the installation is able to show a nice GUI where the live-CD doesn't find a screen.

If I am able to boot into installed Ubuntu, I probably will run into the same graphics problems, but maybe it's easier to fix them on an installed version?


I have faced a similar problem. I only recently updated my packages, so it could be related. I fixed it with a full purge and reinstall of the nvidia drivers:

sudo apt-get -y purge --auto-remove nvidia.*
sudo apt-get update
sudo apt-get -y install nvidia-current-updates nvidia-settings-updates

Worth a try. Probably remove any /etc/X11/xorg.conf if you have one of those.



Try using the USB flash drive or CD-R version of my rEFInd boot manager. If you did not use a separate /boot partition, it should boot up both Linux and Windows with no extra configuration required. You can then install rEFInd to your hard disk by installing the Debian-package version and experiment with boot options and X configuration options from your regular installation, which is likely to be better than experimenting with a live CD.

As to the X configuration, try this in a text-mode login:

  1. Type sudo su. This will log you in as root.
  2. Type Xorg -configure. This should create a file called /root/xorg.conf.new.
  3. Copy /root/xorg.conf.new to /etc/X11/xorg.conf.
  4. Type startx to launch X.

At this point you can begin debugging. X might or might not start. If it does, log out and reboot, which should bring up X normally. If X doesn't start, though, consult any guide you can find on configuring xorg.conf. (I don't have any URLs handy, but I'm sure a Web search will turn up dozens of them.) You'll probably have to adjust the Screen section, and specifically change the Driver line to tell it to use whatever driver works for your system. (The fbdev driver will probably work, but with poor speed. The nv driver might work with better speed or not at all; and nouveau could provide still better speed or fail completely. If you install the Nvidia proprietary driver, it might or might not work; I believe its driver name is nvidia.) You may also need to adjust the ServerLayout section to remove unused Screen devices.


have you tried command update-grub than restart,

if that does not help, try https://help.ubuntu.com/community/Boot-Repair

  • 1
    Why grub if the failure is in the graphic driver? – Alfabravo Oct 13 '15 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.