2

I'm using Ubuntu 12.04.3 LTS and I can't wake up my desktop PC from suspend with a USB device (e.g USB mouse). The entire process of suspending/resume works perfectly but the only way to resume it's by pressing the PWR Button. Here are some logs that I hope could help someone troubleshooting my issue: http://paste.ubuntu.com/6468990/. I tried to follow this guide to enable wake up from USB devices but with no luck: http://bernaerts.dyndns.org/linux/74-ubuntu/220-ubuntu-resume-usb-hid. Any suggestions are appreciated, thanks.

  • External USB devices are powered off to save power - which coincidentally means that they will not work... With a USB mouse, is the light still on during suspend? – Wilf Nov 26 '13 at 17:24
  • Nope, the light on the mouse during suspend is off. But the thing is, with the same setup that i have, wake up with mouse is correctly working on Windows 7 x64 (with also the mouse lights off during suspend). So at least i can say it's not a BIOS setting issue... – demirulez Nov 27 '13 at 10:56
  • Try getting power supplied to it while the computer is suspended first, and then see if it works. Suspend is supposed to be power-saving, so it will probably be buried deep within the code that runs it.... or even the drivers... – Wilf Nov 27 '13 at 17:22
  • Oh, and this, demonstrates the inverse,I don't know whether you could lock the /sys/bus/usb/devices/$port/power/level... files to stop it turning it off when it suspends. Found this as well, which is means that the power could still be supplied during suspend (And I could run systems more efficiently off external hard disk :-) . ) – Wilf Nov 27 '13 at 17:25
  • I tried the solution posted here as you suggested but still no luck, I think that power management on USB devices (and suspend too) has changed a lot, especially in recent kernels (i'm on 3.5.0-18-generic) and those posts are referring to previous versions. Also, as you can see from my logs in the op, i don't have any USBx entries in /proc/acpi/wakeup and i can't manually add them. I'm about to give up on this issue cause it's a jungle literally... – demirulez Nov 28 '13 at 12:46
1

I finally managed to solve this issue by upgrading to the kernel v3.12.0. Now the whole process of suspend/resume, including wake up with my USB mouse works!

  • :-) Stupid 15 characters – Wilf Dec 8 '13 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.