I need to use a software which already works fine in a 32 bit Ubuntu 10.10 virtual machine, with my 64 bit Ubuntu 13.10. I found all the executable files and copy/pasted them into the same directory (/usr/local//), I used the chmod command to make them executable, and as I upgraded my Ubuntu from 13.04 to 13.10 I was able to install the ia32:libs package adding the raring depository in synaptic.

Some of the features (some of the executables) work but the main graphic interface which is run with java does not. In the terminal, when running the command I get the following message, and nothing else happens whereas the graphic window should appear as it does in the virtual machine.

Exception in thread "main" java.awt.HeadlessException
    at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:207)
    at java.awt.Window.<init>(Window.java:535)
    at java.awt.Frame.<init>(Frame.java:420)
    at java.awt.Frame.<init>(Frame.java:385)
    at javax.swing.JFrame.<init>(JFrame.java:174)
    at xedge.ui.Xedge.<init>(Xedge.java:332)
    at xedge.ui.Xedge.main(Xedge.java:7785)

What should I do in order to get the graphic window and the software to work? It seems that I need another version of java but how can I install that properly?


I found a way that seems to work so far.

I had this version of java:

ludovic@ludovic-N61Jq:~$ java -version
java version "1.7.0_25"
OpenJDK Runtime Environment (IcedTea 2.3.12) (7u25-2.3.12-4ubuntu3)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

and found that on the virtual machine where it worked it was rather a version 1.6.xxx, so that I installed this version of java using this webpage.

The process was fairly easy:
1) add a ppa
2) update
3) install the version of java you want

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java6-installer

after that I checked the current version of java used

ludovic@ludovic-N61Jq:~$ java -version
java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)

and run my program which worked. Conclusion is that apparently it is not a 32-bit/64-bit problem but rather a java version problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.