2

variants of this question have been asked, namely, how to place the switcher on both monitors when using compiz and when using Unity, neither are possible from what I see.

Having it on both monitors would be great but I would also be happy to have it on a fixed monitor, so your eyes don't need to jump, or at least on the monitor that has the mouse.

(for the mouse part, I found this bug, but with little activity and older compiz. I'm using 12.04, compiz 0.9.7.12-0ubuntu3)

I want to propose yet another workaround, but for which I need help, namely, to use the "Place" compiz plugin that seems to be able to force placement on the monitor with the mouse. But to do it I need the Class of the Static Switcher window, how can I find it?

  • Hi haelix, what is exactly the question? Perhaps you would need to divide this into more than one post. – Luís de Sousa Nov 26 '13 at 13:29
  • An answer would be valid if it solves the problem in any way (via any workaround). I think people who struggle with this would appreciate the detailed post. – haelix Nov 27 '13 at 12:46
  • But, to put it simply, the question can be what's written in bold. – haelix Nov 27 '13 at 12:47
  • What is in bold is not a question. – Luís de Sousa Nov 27 '13 at 13:57
  • What you're saying is that it doesn't have a question mark, but still, the sentence obviously implies a question, such as: what is the Class of the Static Switcher window? or equivalently, how can I find the Class of the Static Switcher window? (it it's a window at all) – haelix Nov 28 '13 at 7:40
2

If you mean the "alt+tab" (I don't know how it's called), then it doesn't have a Class.

It has however a Name: Switcher.

You can find everything by using xprop:

sleep 2 && xprop -id $(xprop -root _NET_ACTIVE_WINDOW | cut -d\  -f 5)

Type this in a terminal, then press alt+tab without letting the alt key up, and you will get the results for the Switcher window.

EDIT: The following is the full output of xprop for the switcher window. Apparently it doesn't work on every situation.

_NET_WM_ICON_GEOMETRY(CARDINAL) = 7, 733, 48, 48
XKLAVIER_STATE(INTEGER) = 0, 0
WM_STATE(WM_STATE):
        window state: Normal
        icon window: 0x0
_NET_WM_DESKTOP(CARDINAL) = 0
_NET_FRAME_EXTENTS(CARDINAL) = 0, 0, 0, 0
_NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_ABOVE, _NET_WM_ACTION_BELOW
XdndAware(ATOM) = BITMAP
WM_NAME(STRING) = "Switcher"
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_DOCK
_NET_WM_STATE(ATOM) = _NET_WM_STATE_STICKY, _NET_WM_STATE_SKIP_TASKBAR, _NET_WM_STATE_SKIP_PAGER, _NET_WM_STATE_FOCUSED
  • 1
    Hi, nice try, but that only gets the details for the terminal window in my case (even with Alt pressed). Could be we're using different switchers, like I said, I'm using the "static application switcher" (12.04 by default doesn't alt+tab, so I go to CCSM > Window Management > enable Static Application Switcher) – haelix Dec 2 '13 at 9:20
  • I tried enabling the Static Application Switcher in CCSM but I could still get the results. By the way I have alt+tab without enabling this option. I don't remember the default behaviour of Ubuntu Precise nor how I changed it though :) – Stefanos Kalantzis Dec 2 '13 at 14:16
  • You might be using Unity, I don't. I think it was incorrect to say 'the default is no Alt+Tab'. Actually, after switching to gnome fallback, then you don't get Alt+Tab – haelix Dec 3 '13 at 14:45
  • Oh.. I see. You should mention that you don't use unity in the question then :) – Stefanos Kalantzis Dec 6 '13 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.