11

My system runs on Ubuntu 12.04 and I use the transmission bit-torrent client which was installed on it. It works just fine but I would like it to open as soon as I get on the system instead of having to open it. It's not a big problem but if I forget, the torrents won't begin downloading. Thank in advance if anyone can help.

2 Answers 2

18
  1. Open Dash (hit Win/Super key by default). Enter Startup Applications then hit Enter
  2. Click Add, enter name Transmission, enter command transmission-gtk -m, click Add.

You've done it.

15

You have a little program called "startup applications". If you open that (open dash and search for startup and you will see it). Add Transmission to that and you will be set.

When you first open the program, click add, and browse for the app: it is in /usr/bin, in other words the root filesystem then usr, then bin. Hit the first item with a single click and hitT to jump down to the T's. A file named "transmission" will be there, that is what you want to add.

5
  • 1
    That worked fine but now the program opens in full screen. Is there a way to open it minimized or better yet on the tray. I want it to run so as to upload and download but as a backround program and only lanch manually.
    – mdoxst
    Commented Nov 25, 2013 at 23:49
  • 5
    try adding --minimized after the entry to start transmission in the start-up menu. I found that here: trac.transmissionbt.com/ticket/1002 Commented Nov 26, 2013 at 2:16
  • Tried usr/bin/transmission-gtk-minimized and usr/bin/transmission-gtk-m also with one - and two -- but nothing works. Its either on fullscren or not at all. Also tried to associate it with Cuttlefish but I get the same result.
    – mdoxst
    Commented Nov 27, 2013 at 12:11
  • 1
    I tested it, it works. The command is actually: /usr/bin/transmission-gtk --minimize. There needs to be a space between the k and the --minimized. I restarted and transmission is started and sits in upper right on the panel along with my dropbox icon and clock and all that sort of stuff :) I am running 13.10 with the Unity desktop. Commented Nov 28, 2013 at 11:46
  • There is no option "--minimize", it is indeed "--minimized". You can try it on a terminal window.
    – streppel
    Commented Apr 24, 2014 at 3:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .