I have a problem that's been bugging me since Ubuntu 11.04 Beta 2:

My printer (a HP LaserJet P1005) have been installed and working in Ubuntu 10.10. After upgrading to Ubuntu 11.04 Beta 1, it still worked, but after receiving updates from that point on, it never printed a single sheet ever since.

It's displayed as set up, working and ready to print, but hitting the print button does absolutely nothing. It won't even print a test page. This problem goes for BOTH of my laptops. Upgrading to the final version of Natty didn't help either.

Since I saw no printer icon on the top bar, I tried logging on to Ubuntu Classic, but this did not work. I even tried plugging in a different printer. That didn't work either.

How can I resolve this problem?

3 Answers 3


did you try to install hp software (as i know there is an hp driver and tool for linux) but before you install it try to remove the printers already define by ubuntu check here http://hplipopensource.com/hplip-web/index.html and try maybe it will work if it does not work and you mention that another printer also didn't work then it looks like a cups problem try to reinstall from the synaptic

  • AWESOME!! I owe you BIG TIME! After running the installer from your link, it prompted me with some missing packages which I found and installed from the package manager. After a reboot, the printer was up and running. AWESOME! How do you vote an answer up in this forum??
    – Bob Newm'n
    Apr 29, 2011 at 23:04
  • arh, them little arrows ;) one upvote coming your way!!!!
    – Bob Newm'n
    Apr 29, 2011 at 23:06
  • Thanks a lot @Bob Newm'n and @nadeem ! Your solution also worked for my network Laserjet P3005dn printer.
    – Alkalyzer
    May 26, 2011 at 9:47

Same problem for me on Ubuntu 11.04, downloaded the latest driver and followed the instructions on this help page http://hplipopensource.com/hplip-web/install/install/index.html

Problem Solved.


The problem on my machine was the package foo2jzs, which was set to delete the proprietary plugins: https://bugs.launchpad.net/foo2zjs/+bug/783389

I had to run "sudo hp-plugin" every time.

Problem solved after patch: http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/foo2zjs/oneiric/revision/53#debian/patches/95-udev-firmware-script-no-hplip-rules-removal.patch

Not the answer you're looking for? Browse other questions tagged or ask your own question.