0

I have a dual boot system with two hard drives -- one for Windows 7 and the other for Ubuntu (now 3.5.0-43). I ran the most recent Ubuntu updates and lost my Windows 7 entry in grub. I've attempted running sudo update-grub2, os-prober, manually adding the "40_custom" entry in /etc/grub.d/, and surfing around for a solution. So far, it seems that nobody else has solved this problem.

I ran boot-repair and created the paste link -- http://paste.ubuntu.com/6466121/. Another oddity is that I am not able to do anything other than generate the "BootInfo" using boot-repair. I only get the "About", "Quit", and "Create a BootInfo summary (to get help by email or forum)" when I run the application.

I appreciate any information for how I might be able to re-add this entry... and how I can prevent future updates/upgrades from breaking this configuration again.

0

Line 795 of your Boot-Repair log, we can see the blkid command returns nothing. You can mark yourself "Affected" by this bug: https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1216688

Running Boot-Repair from a live-disk (eg from Boot-Repair-Disk) may solve the issue. If not, indicate the new URL that will appear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.