0

I've been trying to install google earth and get these dependency issues related to lsb-core. When I try to install lsb-core I get more dependency issues with it.

jacob@jacob-desktop:~$ sudo apt-get install lsb-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 google-earth-stable : Depends: ia32-libs but it is not installable
 lsb-core : Depends: lsb-invalid-mta (>= 4.1+Debian11ubuntu4) but it is not going to be installed or
                     mail-transport-agent
            Depends: at
            Depends: m4
            Depends: mailx or
                     mailutils but it is not going to be installed
            Depends: ncurses-term but it is not going to be installed
            Depends: pax
            Depends: alien (>= 8.36) but it is not going to be installed
            Depends: libc6-i386 but it is not going to be installed
            Depends: lib32z1 but it is not going to be installed
            Depends: lsb-security (>= 4.1+Debian11ubuntu4) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

any advice??

  • Ok got passed that. Finally got lsb-core installed now when I try the google earth install I get this error. – jakey Nov 25 '13 at 0:25
1

The answer is at the bottom of your question. Run:

sudo apt-get update

sudo apt-get -f install

or

sudo apt-get autoremove

or

sudo apt-get autoclean

anything that suits you well.

0

Run these two commands on terminal,

sudo apt-get clean
sudo apt-get -f install

Not the answer you're looking for? Browse other questions tagged or ask your own question.