JAVA being blocked because of security level. However, I am aunable to alter security levels in Ubuntu.

I have dated to the latest JAVA:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer

pst007x@pst007x-Serval-Professional:~$ java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)

I get the error:


I select:


Then a pop up:

Your Java version is out of date.

Click Update to install the recommended latest version. Click Block to stop Java content in your browser or Later to continue and be reminded again later.

I select LATER, then it fails, saying:

Your security settings have blocked the application from running with an out of date or expired version of JAVA

.... But I am running the latest Linux version...

Has Ubuntu stopped supporting JAVA now?

Help please! :-)

JAVA website:

Verified Java Version Completion checkmark Congratulations!

You have the recommended Java installed (1.8.0-ea).

This is the site that fails: JPL


I just went to the site you showed and had no issue. I am using opendjdk7 and the icedtea web browser plugin via the software center and I am not using the java provided by oracle. Do you need the actual java? If not you could remove it and use openjdk or just the openjre if you do not need the development stuff.

As for Ubuntu and java, Oracle changed the licensing and java cannot be provided. It is not free software. You can read the licensing to understand it better. So, as such, Ubuntu cannot provide it through its own sources (that is why you had to set up a ppa to get it).

As for the errors you are getting, they could be coming from the website's interaction with your browser. I know we have software at work that is crazy finicky with java versions.

If you do not need the actual java, give openjre/jdk a try and the icedtea plugin.

  • Tried those, but the same issue. that's why i installed from the PPA. Where are my security settings for JAVA, the site does not recognise my version, though I have tried all versions, 6,7 and 8.. Do you know? Usually I would right click on a JAVA window, and get the options, however now I get a limited console, with no security options. I altered the JAVA..POLICY, to allow everything, but still the same error... Cheerss – pst007x Nov 24 '13 at 22:27
  • I removed all instances of JAVA and installed as you recommended, rebooted, and after a few security warnings the site run. Many thanks, appreciated.. – pst007x Nov 24 '13 at 23:01

I find these "it works on my machine" and "use what I use" answers annoying. If you're using Oracle's JDK and having this problem on Linux, add the following line to your ~/.java/deployment/deployment.properties file:


Then restart your browser. This is the Linux equivalent of all the Windows and Mac OS X specific "set your security level to Medium" instructions polluting the "how do I do this on Linux" search results.

Good luck!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.