I have a Mac and am dual booting Ubuntu. I booted from a USB and used GParted to shrink the Ubuntu partition leaving me with about 100G of free space. I want to use this to increase the OS X partition space. GParted will not let me increase the OS X partition size (although it will let me decrease it). I've also tried using Disk Utility from OS X.

When I had the 100G of unallocated space, Disk Utility would report "MediaKit reports partition (map) too small." I also tried creating a new partition of both "unformatted" and "cleared." Now when I use Disk Utility, it says "Preparing to resize," but doesn't move on. It doesn't lock up, but even after half an hour it is still "preparing to resize."

GParted still can't increase the OS X partition size either (same as before). I also can't create an hfs+ partition with the unallocated space. The option is there, but it is grayed out.

I've seen this question, but the solutions all involve booting the OS X CD, which I do not have. Using df does not list the OS X partition either, but Ubuntu does not appear to have gpt anyway.

In general, I've read that I need to repair the partition table, but the only ways from OS X that I've found to do this require having a CD to boot from.

I've also read that since I used GParted to create the free space, I need to use GParted to resize the partition or at least put it in a resizable state, but nothing I've done will allow me to resize the OS X partition.

  • 1
    The GParted Features page indicates that growing hfs or hfs+ is not supported. Further I am not aware of any free software tools that support growing these Max OS X native file systems. – Curtis Gedak Nov 25 '13 at 20:54

If the diagnosis that there's a problem with the partition table is accurate, I recommend you install the gdisk package in Ubuntu (or download and install the Mac version from Sourceforge), launch it on your disk, and use the v option to check for errors. If you find any, check the gdisk documentation on repairing the disk or report back here with details. (Edit your original question and post the gdisk output there.)

It's also possible that you're running into problems related to a hybrid MBR. If so, it's possible that converting the hybrid MBR into a conventional protective MBR will fix the problem; however, this might render Linux (and Windows, if it's also installed) unbootable. There are ways to correct this -- you can either regenerate a hybrid MBR after you resize your partitions or convert Linux to boot in EFI mode.

EDIT: I have a new thought on this issue, which is that you may not have sufficient space between your partitions. OS X's Disk Utility likes to see at least 128MiB of space between existing partitions. If that space isn't present, it will often refuse to work on the disk, although I don't recall the error message it gives. Since you haven't posted your partition table details, it's hard to know if this is a plausible explanation for your problem -- you presumably have ~100GiB of free space somewhere, but it might not be in the right location to please Disk Utility. If this explanation is correct, you may need to resize one or more Linux partitions to ensure that there's free space after every OS X partition. Posting the output of sudo parted /dev/sda unit s print (typed in an Ubuntu Terminal window) will show us how your disk is laid out, which should be helpful in determining if this hypothesis has any merit.

  • I installed and ran gdisk v on /dev/sda2 (the OS X partition). It said there were no problems found. When I first ran it, it said "partition table scan" and said that MBR/BSD/APM/GPT are "not present" and then "Creating new GPT entries" (which seems to do nothing) – Explosion Pills Nov 24 '13 at 21:15
  • You run gdisk, like any other partitioning tool, on the entire disk -- that is, /dev/sda, not on a single partition, like /dev/sda2. – Rod Smith Nov 24 '13 at 22:24
  • Sorry, I didn't know I was supposed to know that. Now it says that MBR is hybrid and GPT is present. No problems reported after running v. Is it time to attempt to convert the MBR? – Explosion Pills Nov 25 '13 at 0:19
  • Converting the hybrid MBR to a protective MBR might help; however, I've also had another idea -- see my edit above. – Rod Smith Nov 25 '13 at 17:57
  • I had to boot Ubuntu from USB to move the Ubuntu partition to the right (moving the unallocated space to the left, directly to the right of the OS X partition). OS X happily extended after that. – Explosion Pills Nov 25 '13 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.