1

After upgrading to 13.10, nautilus stopped producing and showing thumbnail icons for images and videos.

Also in KDE environment, there's no longer a standard icon for nautilus in start menu (or its submenus).

How should I solve these problems with nautilus.

Edit:

enter image description here

‌ ‌Before upgrading both could have proper thumbnails.

  • Could you add a screen-shot of the first problem? For the second ,you may need to create or edit a launcher file. – Wilf Nov 24 '13 at 13:54
  • added‌‌‌‌‌‌‌‌‌‌‌‌‌‌. – user126106 Nov 24 '13 at 14:13
  • 1
    Here's a rather accurate solution for 13.10 and all past versions: askubuntu.com/a/179107/17065 Note the change in path from '.thumbnails' to '.cache/thumbnails' – isaaclw Dec 27 '13 at 16:37
3

For the first one, you just may need to edit the settings: Select preferences Preferences Dialog

If that fails, you may need to install the programs to thumbnail the files:

apt-get install....

Probably atleast one of these - at a guess (EDIT: this was for Ubuntu 13.04/10 - you can search here for thumbnailer packages - e.g. for 16.10):

gnome-sushi - file previewer 
libnautilus-extension1a - libraries for nautilus components - runtime version
nautilus-actions - nautilus extension to configure programs to launch
libthumbnailer-dev - development files for thumbnailer
libthumbnailer0 - generate thumbnails from files
gnome-exe-thumbnailer - Wine .exe and other executable thumbnailer for Gnome
gnome-raw-thumbnailer - RAW file thumbnailer for GNOME 
ooo-thumbnailer - thumbnailer for OpenOffice.org documents
kde-thumbnailer-deb - KDE plugin to show thumbnails of Debian package files
kdegraphics-strigi-plugins - transitional package for kdegraphics-related plugins
kdegraphics-thumbnailers - graphics file format thumbnailers for KDE SC
ffmpegthumbnailer - fast and lightweight video thumbnailer
ffmpegthumbnailer-dbg - debugging informations for ffmpegthumbnailer
ffmpegthumbs - video thumbnail generator using ffmpeg

For your second problem, remove this line from /usr/share/applications/nautilus.desktop (The launcher file for Nautilus - EDIT: For newer versions of Ubuntu use org.gnome.Nautilus.desktop instead of nautilus.desktop) :

OnlyShowIn=GNOME;Unity;

You can edit it using nano for the entire system:

sudo nano /usr/share/applications/nautilus.desktop

or preferably for the current user:

cp /usr/share/applications/nautilus.desktop ~/.local/share/applications/
nano /usr/share/applications/nautilus.desktop
  • It was solved. thnx. – user126106 Nov 24 '13 at 14:27
  • 1
    Updated with answer and a guess for first problem - even though you may have solved it anyway. – Wilf Nov 24 '13 at 17:18
  • 1
    Editing files in /usr/share is generally best avoided, since they can be overwritten by the package manager; copying .desktop files to ~/.local/share/applications and editing them there is more reliable. This should cause the system copy of the .desktop file to be ignored. askubuntu.com/a/117526/309061 – GKFX Jan 12 '17 at 19:08
  • 1
    @GKFX - thanks I know that now but apparently not 3 years ago :) – Wilf Jan 14 '17 at 9:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.