1

I'm trying to install Ampl but I encountered some problems. I'm following these instructions: www.netlib.org/ampl/student/linux/README

  1. I downloaded ampl.gz and cplex.tar (from www.netlib.org/ampl/student/linux);
  2. I created a directory bin in my home folder;
  3. I moved the two files to the folder bin/ampl;
  4. I gave the following commands:

    gzip -dN ampl.gz cplex.tgz
    tar xf cplex.tar
    chmod +x ampl
    rm cplex.tar
    
  5. I added this string to the end of the file:

    export PATH="/home/davide/bin/ampl:$PATH"
    
  6. I saved the file and I have logged out.

when I try to give the command ampl < file.run the terminal does not recognize the command. Where am I wrong?

echo $PATH
/home/davide/bin/ampl:/home/davide/bin:/opt/texbin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games


davide@davide-X201EP:~/bin/ampl$ ampl < dieta.run
bash: /home/davide/bin/ampl/ampl: File o directory non esistente
davide@davide-X201EP:~/bin/ampl$ ls -l
totale 5064
-rwxrwxr-x 1 davide davide 1017156 giu 25 16:21 ampl
-rwxr-xr-x 1 davide davide 4061168 giu  6 22:11 cplex
-rw-r--r-- 1 davide davide     363 ott 18  2012 dieta.dat
-rw-r--r-- 1 davide davide     389 ott 25 10:32 dieta.mod
-rw-r--r-- 1 davide davide      77 nov 22 19:12 dieta.run
-rw-r--r-- 1 davide davide     119 ott 25 10:30 dieta.run~
-rw-r--r-- 1 davide davide    3153 gen  3  2001 LICENSE
-rw-r--r-- 1 davide davide   79082 gen 14  2011 README
davide@davide-X201EP:~/bin/ampl$ ./ampl < dieta.run
bash: ./ampl: File o directory non esistente
davide@davide-X201EP:~/bin/ampl$ uname -m
x86_64
davide@davide-X201EP:~/bin/ampl$ file $(which ampl)
/home/davide/bin/ampl/ampl: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, stripped
davide@davide-X201EP:~/bin/ampl$ ldd $(which ampl)
non è un eseguibile dinamico

I tried to install ia32-libs but:

davide@davide-X201EP:~$ sudo apt-get install ia32-libs
[sudo] password for davide: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
ia32-libs : Dipende: ia32-libs-multiarch
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
davide@davide-X201EP:~$ sudo apt-get install ia32-libs-multiarch
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
ia32-libs-multiarch:i386 : Dipende: bluez-alsa:i386 ma non sta per essere installato
                        Dipende: libgettextpo0:i386 ma non sta per essere installato
                        Dipende: gstreamer0.10-plugins-base:i386 ma non sta per essere installato
                        Dipende: gstreamer0.10-plugins-good:i386 ma non sta per essere installato
                        Dipende: gstreamer0.10-fluendo-mp3:i386 ma non sta per essere installato
                        Dipende: gtk2-engines:i386 ma non sta per essere installato
                        Dipende: gtk2-engines-murrine:i386 ma non sta per essere installato
                        Dipende: gtk2-engines-pixbuf:i386 ma non sta per essere installato
                        Dipende: gtk2-engines-oxygen:i386 ma non sta per essere installato
                        Dipende: gvfs:i386 ma non sta per essere installato
                        Dipende: ibus-gtk:i386 ma non sta per essere installato
                        Dipende: libacl1:i386 ma non sta per essere installato
                        Dipende: libao4:i386 ma non sta per essere installato
                        Dipende: libasound2:i386 ma non sta per essere installato
                        Dipende: libasound2-plugins:i386 ma non sta per essere installato
                        Dipende: libasyncns0:i386 ma non sta per essere installato
                        Dipende: libattr1:i386 ma non sta per essere installato
                        Dipende: libaudio2:i386 ma non sta per essere installato
                        Dipende: libcanberra-gtk-module:i386 ma non sta per essere installato
                        Dipende: libcap2:i386 ma non sta per essere installato
                        Dipende: libcapi20-3:i386 ma non sta per essere installato
                        Dipende: libcups2:i386 ma non sta per essere installato
                        Dipende: libcupsimage2:i386 ma non sta per essere installato
                        Dipende: libcurl3:i386 ma non sta per essere installato
                        Dipende: libdbus-glib-1-2:i386 ma non sta per essere installato
                        Dipende: libesd0:i386 ma non sta per essere installato
                        Dipende: libfontconfig1:i386 ma non sta per essere installato
                        Dipende: libfreetype6:i386 ma non sta per essere installato
                        Dipende: libgail-common:i386 ma non sta per essere installato
                        Dipende: libgconf-2-4:i386 ma non sta per essere installato
                        Dipende: libgdbm3:i386 ma non sta per essere installato
                        Dipende: libglapi-mesa:i386 ma non sta per essere installato
                        Dipende: libglu1-mesa:i386 ma non sta per essere installato
                        Dipende: libgphoto2-2:i386 ma non sta per essere installato
                        Dipende: libgphoto2-port0:i386 ma non sta per essere installato
                        Dipende: libgtk2.0-0:i386 ma non sta per essere installato
                        Dipende: libmpg123-0:i386 ma non sta per essere installato
                        Dipende: libncursesw5:i386 ma non sta per essere installato
                        Dipende: libnspr4:i386 ma non sta per essere installato
                        Dipende: libnss3:i386 ma non sta per essere installato
                        Dipende: libodbc1:i386 ma non sta per essere installato
                        Dipende: libopenal1:i386 ma non sta per essere installato
                        Dipende: libpulse-mainloop-glib0:i386 ma non sta per essere installato
                        Dipende: libqt4-dbus:i386 ma non sta per essere installato
                        Dipende: libqt4-network:i386 ma non sta per essere installato
                        Dipende: libqt4-opengl:i386 ma non sta per essere installato
                        Dipende: libqt4-qt3support:i386 ma non sta per essere installato
                        Dipende: libqt4-script:i386 ma non sta per essere installato
                        Dipende: libqt4-scripttools:i386 ma non sta per essere installato
                        Dipende: libqt4-sql:i386 ma non sta per essere installato
                        Dipende: libqt4-svg:i386 ma non sta per essere installato
                        Dipende: libqt4-test:i386 ma non sta per essere installato
                        Dipende: libqt4-xml:i386 ma non sta per essere installato
                        Dipende: libqt4-xmlpatterns:i386 ma non sta per essere installato
                        Dipende: libqtcore4:i386 ma non sta per essere installato
                        Dipende: libqtgui4:i386 ma non sta per essere installato
                        Dipende: libqtwebkit4:i386 ma non sta per essere installato
                        Dipende: librsvg2-common:i386 ma non sta per essere installato
                        Dipende: libsane:i386 ma non sta per essere installato
                        Dipende: libsdl-mixer1.2:i386 ma non sta per essere installato
                        Dipende: libsdl-image1.2:i386 ma non sta per essere installato
                        Dipende: libsdl-net1.2:i386 ma non sta per essere installato
                        Dipende: libsdl-ttf2.0-0:i386 ma non sta per essere installato
                        Dipende: libsdl1.2debian:i386 ma non sta per essere installato
                        Dipende: libsqlite3-0:i386 ma non sta per essere installato
                        Dipende: libssl0.9.8:i386 ma non sta per essere installato
                        Dipende: libssl1.0.0:i386 ma non sta per essere installato
                        Dipende: libstdc++5:i386 ma non sta per essere installato
                        Dipende: libstdc++6:i386 ma non sta per essere installato
                        Dipende: libxaw7:i386 ma non sta per essere installato
                        Dipende: libxml2:i386 ma non sta per essere installato
                        Dipende: libxp6:i386 ma non sta per essere installato
                        Dipende: libxslt1.1:i386 ma non sta per essere installato
                        Dipende: libxss1:i386 ma non sta per essere installato
                        Dipende: libxtst6:i386 ma non sta per essere installato
                        Dipende: odbcinst1debian2:i386 ma non sta per essere installato
                        Dipende: libpulsedsp:i386 ma non sta per essere installato
                        Dipende: xaw3dg:i386 ma non sta per essere installato
                        Raccomanda: libgl1-mesa-glx:i386 ma non sta per essere installato
                        Raccomanda: libgl1-mesa-dri:i386 ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
  • What was the error displayed on the terminal? – Avinash Raj Nov 23 '13 at 14:54
  • davide@davide-X201EP:~/bin/ampl$ ampl < dieta.run bash: /home/davide/bin/ampl/ampl: File o directory non esistente – Davide Nov 23 '13 at 15:29
  • 'File o directory non esistente' is the italian translation of 'No such file or directory' – Davide Nov 23 '13 at 15:47
  • I think so...I don't need gjh.gz gurobi.tgz lpsolve.gz minos.gz snopt.gz so I didn't install them. – Davide Nov 23 '13 at 16:06
  • Did you check if in /home/davide/bin/ampl/ there is a file named ampl and it's executable? Try to launch ampl directly from that folder – user218661 Nov 23 '13 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.