2

First of all I would like to mention that, I'm completely aware of the duplication rule of this forum and this post has been made only after due research on the topic.

Problem

I dual-booted a pre-installed Windows 8 laptop with Ubuntu 13.10 but now when I power on the system, Windows Boot Manager boots into Windows (without asking which OS I would like to boot into), One probable reason for the same can be that, windows may have not detected the presence of Ubuntu as the secondary OS. (I've checked the msconfig utility which only lists windows 8.1)

This is what I have tried

I've tried Boot Repair utility which I found mentioned at many places in the Ubuntu Forums as well, But this reported an error (I can mention the error If anyone needs it). I've also turned off "secure boot" and "fast boot" in windows.

Weird behaviour

The thing I don't understand is, When I power off the system by long pressing the power button and then start it again, GRUB Bootloader magically appears! But, When I Shutdown the system from within Ubuntu or Windows, then Windows Boot Manager boots up directly into Windows...

Another weird thing here is, When I plug-in the Linux Live USB and then turn on the system, and keep pressing the F11 key I can load the GRUB Bootloader. But this only happens when the Linux Live USB Key is plugged into a port...

What I ultimately want to achieve

So, At the first priority, I would like to have Windows Boot Manager load up at the startup dispalying a list of available OS to boot.

And if that's not possible, then GRUB should load up with the same options i.e. an OS list to choose from...

  • 1. boot into your live usb 2. Also have a look using gparted at how many actual partitions there are and 3. open a cli and sudo grub update and post that output on here while still live on the USb... – Hilary Albutt Nov 24 '13 at 16:24
  • I can't connect to the internet, from Linux as currently my USB Mobile Broadband is not getting detected in linux... But, I can look at the partitions. Sequentially there are: OEM, Recovery, EFI, Windows, Linux Root, Linux Swap, Recovery, Recovery – 0x550x42 Nov 26 '13 at 12:55
0

You could try typing the following into a Windows administrator command prompt:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

That tells Windows to use Grub as the bootloader. For me, this prevented the system booting straight into Windows automatically, so I could choose between Windows/Ubuntu.

What is the error that Boot-Repair gives you? I don't know how to (or if it's even possible to) get the Windows Boot Manager to recognize Ubuntu and give it as an option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.