2

I am on Ubuntu 12.04 64bit. As of recently I started getting message that I need to upgrade the system in order to install new kernel. Look at the image.

However, during this upgrade they will remove some of tools which I do not want to be removed.

The same thing happened a few months ago and I upgraded to install kernel and as of then some Java apps stopped working, especially those who were depended on 32bit libraries I forcibly installed.

How to stop this happening? Why are they forcing me to upgrade when 12.04 was supposed to be LTS?

  • How do you exactly forced 32bit libraries? – xangua Nov 23 '13 at 8:22
  • Some java apps from a specific web service tools needed them. So I previously installed them using --force or similar switch. I can't remember at this point since I followed online tutorial. – ubuntico Nov 23 '13 at 8:26
  • That is not really helpful.... and the package for 32bit libraries is ia32-libs-multiarch , I don't see why you needed to force install. – xangua Nov 23 '13 at 8:29
  • It's not important now. They are gone with the last kernel upgrade. Can you help me with this one? – ubuntico Nov 23 '13 at 8:36
  • 1
    Sorry, I just reread your question. Is it actually "How do I stop Ubuntu from suggesting to upgrade to a non-LTS release?" ? – ntninja Nov 23 '13 at 19:44
2
  1. Open the Dash (By pressing the "Super-Key" / "Windows-Key" / "Ubuntu-Key" / "Command-Key")
  2. Search for "Software"
  3. Open the application "Software & Updates"
  4. Select the "Updates" tab
  5. Next to "Notify me of a new Ubuntu version:" select "For long-term support versions": Software & Updates
  6. Enter your password and press enter
  7. Close the "Software & Updates" application
  8. Allow the system to search for updates: enter image description here
0
  1. Open "Software & Updates"
  2. Select "Updates" tab.
  3. At that tab, there is an option says "Notify me of a new version"
  4. Open the list and choose "For long term support versions"

You will only get notified for LTS updates from now on.

0

So what was the problem?

Well it is easy to configure upgrade the way you want.

  • Press Alt+F2 and execute software-properties-gtk.

  • It will open Software Sources window. Go to Updates tab and set the value for Notify me for new Ubuntu version: to For long term support versions.

  • If you want to stop the upgradation message, set Automatically check for Updates: to Never

  • Then Close the window and upgrade your repository:

    sudo apt-get update
    

That's all. Reply if you need any further assistance..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.