1

I am using Ubuntu 13.04 on my laptop.

I ssh to my EC2 instance which is running Ubuntu 12.04.3 and every time I run sudo apt-get update, it prints some lines and then the terminal freezes.

ubuntu@ubuntu:~$ sudo apt-get update
Hit http://us-east-1.ec2.archive.ubuntu.com precise Release.gpg
Hit http://us-east-1.ec2.archive.ubuntu.com precise-updates Release.gpg
Hit http://us-east-1.ec2.archive.ubuntu.com precise Release
Hit http://us-east-1.ec2.archive.ubuntu.com precise-updates Release                                 
Hit http://us-east-1.ec2.archive.ubuntu.com precise/main Sources

(no further output)

Similarly it freezes with a blank screen when open a file (or new file) in vim, while nano works perfectly fine.

I would also like to point out that this wasn't happening a day back and before this issue cropped up I ran sudo apt-get update && sudo apt-get dist-upgrade on ec2 instance which worked fine as usual.

This has made my AWS instance unusable which is where I do most of my work. Any ideas as to what might be causing this and what might fix it?

I have tried re-installing vim (which works by the way) but it still freezes, I feel helpless, please help me.

Note: Interestingly, I can still edit files in vim, I just can't see anything happening on the terminal.

1 Answer 1

2

Changing the MTU value on ec2 solved it for me...

sudo /sbin/ifconfig eth0 mtu 1492
1
  • U are the best! 1000 working value for me. Thnks. Jan 24, 2020 at 11:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .