2

This question already has an answer here:

I had Windows 7 and Ubuntu 12.04 installed in my system. I removed Ubuntu and installed it again. When I restarted the system, it showed:

Error : Unknown filesystem 
grub rescue > 

When I use the ls command I am getting this

(hd0),(hd0,msdos8),(hd0,msdos7)(hd0,msdos6)(hd0,msdos5)
(hd0,msdos4)(hd0,msdos3)(hd0,msdos2)(hd0,msdos1)

But when I run ls (hd0)/ it's saying unknown partition. The same case for all the others (hd0,msdos1) to (hd0,msdos8).

I tried booting a new OS from USB, and I am getting

Error loading operating system

I also tried Super Grub from USB, but I still get the same error Error loading operating system.

Please let me know what to do now.

marked as duplicate by karel, Zanna, Tom Brossman, pomsky, Fabby Nov 8 '18 at 10:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Which software did you are used to make bootable super grub usb? – Avinash Raj Nov 23 '13 at 4:32
  • Try reinstalling GRUB from the LiveCD as a first step in troubleshooting check whether that helps. – vembutech Jun 1 '15 at 14:10
0
  1. Boot from an Ubuntu live CD

  2. Mount the partition. Create a new folder in your media folder. sudo mkdir /media/ubuntu. Then simple mount your partition to that folder. sudo mount /dev/sdxx /media/ubuntu

  3. Run these commands

    sudo mount --bind /dev /media/ubuntu/dev
    sudo mount --bind /sys /media/ubuntu/sys
    sudo mount --bind /proc /media/ubuntu/proc
    
  4. Change the root directory to the one on your ubuntu partition.

    sudo chroot /media/ubuntu/
    
  5. Install grub2 again:

    grub-install /dev/sdx
    

    NB: replace sdx with the correct drive name

Not the answer you're looking for? Browse other questions tagged or ask your own question.