Today when I went ahead with Natty installation I had selected btrfs for root filesystem. To my utter surprise I was presented with the screen

Unknown filesystem
grub rescue >

None of the options I tried like Y, yes did not work. Later I again installed Natty with ext4 filesystem.

Why do such errors appear?

  • I need no more answers for the question as I have reinstalled Natty in an ext4 partition. – Chethan S. May 4 '11 at 11:52

btrfs is considered experimental and unless you're very adventurous, you should avoid using it. There is neither a fsck tool available in case the btrfs filesystem becomes corrupt (after a power failure for example).

An excerpt from the release notes:

The btrfs filesystem is considered experimental in this release. It can generally be installed and used, but with a number of problems. You should only use it if you are comfortable with dealing with problems and helping us resolve them.

  • As the btrfs wiki notes: "Note that Btrfs does not yet have a fsck tool that can fix errors. While Btrfs is stable on a stable machine, it is currently possible to corrupt a filesystem irrecoverably if your machine crashes or loses power on disks that don't handle flush requests correctly. This will be fixed when the fsck tool is ready."
  • GRUB cannot detect a btrfs installation within an encrypted disk, and fails to set up the correct kernel parameters. (757631)

GRUB can actually boot from btrfs filesystems (instructions), but note that Ubuntu still consider btrfs as experimental.

  • I knew it was experimental, but remember seeing people boasting of using btrfs and getting fast boot times. How could they boot into Ubuntu when I got unknown filesystem. – Chethan S. Apr 30 '11 at 2:02
  • 1
    @Chethan S.: Install the bootloader to either the MBR of the disk or create a new /boot partition, formatted ext2. See the Ubuntu Wiki article. – Lekensteyn Apr 30 '11 at 7:34
  • 3
    GRUB can boot from btrfs in 11.04. There are problems, certainly, but it is inaccurate to say "GRUB cannot boot from that filesystem". – Colin Watson May 4 '11 at 8:17
  • I've successfully booted from btrfs /, both single disc and a 4-disc btrfs multidevice system. I didn't do anything special to make that happen :). It was slow as molasses, but it worked. – RAOF May 4 '11 at 9:09
  • @Colin: I've made the answer more correct now. – Lekensteyn May 4 '11 at 12:13

btrfs is the future of filesystems check: https://btrfs.wiki.kernel.org/index.php/Main_Page But it is just a child and not yet ready completely. btrfs is very fast, but I will not recommend it for a person who wants a stable system. If you want to see some technical aspects of btrfs you can visit http://lwn.net/Articles/342892/


First, try reinstalling GRUB. Is there any output from grub-install when you do that? If so, post it here.


In this case I'm going to go out on a limb and guess that your problem was a version of grub that did not, or did not correctly, support btrfs. There are two solutions. Either give your system a separate, ext2/3 boot partition, or use the latest version of grub that supports btrfs in a much cleaner manner.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.