2

I have a VM installed in my windows 7 PC, and I want to install an Ubuntu 13.04 on it, as a new virtual disk. I have this machine:

Intel Core i7-2600k CPU @ 3.40Ghz - 8 GB RAM - 64 bit operating system

I get this message:

Kernel requires x86-64 CPU, but only detects i686

Why is this? I think I´m missing something really silly here...

4

Check to see if your VM's cpu has any additional features enabled like VT (virtualization technology), as well as if the machine is running in BIOS or EFI mode (In virtualbox these are all listed in under CPU, however in VMware player only some are listed the rest can only be configured by editing the vm config file manually in notepad. The best option is to have all such things turned OFF unless you really need them, which is the default setting of most VM softwares.

Check to make sure you choose the correct VM type, for example in VMware Player you would choose Ubuntu 64 rather than Ubuntu when deciding what type of VM profile to use.

If the issues persist, try uninstalling the VM software and re-installing (or if possible updating to a new release).

Last but not least check you HOST bios or uefi, MANY VM PROGRAMS REQUIRE VT or VT-x etc to be enabled on the host to run 64bit vms.

|improve this answer|||||
4

I know it may sound stupid but I was having the same issue with Virtual Box.

If you do not select the Ubuntu x64 for the operating system drop-down (ie you might have selected just Ubuntu, there should be two options for the Ubuntu distribution). The system auto boots to a virtual i686 instead of the required X86-64.

|improve this answer|||||
  • That actually happened to me with downloaded HortonWorks VM, even after VT was enabled in the BIOS I kept receiving the message. Thanks for this answer, I thought it to silly to consider so was looking elsewhere. – LAFK says Reinstate Monica Oct 11 '14 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.