3

I'm running Ubuntu 13.10 on a new 11,3 Macbook Pro (dual booting) and I see this random HDD (looks like my cryptswap partition) listed under Devices in my file browser.

File Browser

As you can see it's a bit of an eyesore and I can't even access it:

enter image description here

How can I remove this from this list?

2
  1. Press Windows key and search for the application called "Disks"
  2. Select the HDD that contains the partition that you want to hide
  3. At the right, select the partition to hide and press the "More Actions" >> "Edit Mount Options..."
  4. In the "Mount Options" window, select "OFF" for "Automatic Mount Options" and uncheck the "Show in user interface" box (also "Mount at startup" if you won't use it)

Capture of "Mount Options" dialog

0

You can use GParted and a Live System and mark the partition as hidden. Nautilus doesn't offer such functionality hence you may have to use some Filesystem tools to make your wishes true.

0

Have you tried right-clicking on it, and hitting "remove?" If that doesn't work, then it may be corrupted. Ubuntu has a funky way of dealing with corrupted HDD's (I have experience :)) If it's a partition, then there's no way to "physically" remove it from the system. You can just hit the "remove" button. If that doesn't work, then something is wrong with it.

Hope that helps! --Michael

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.