Can I somehow use gvim to compose my email messages in Thunderbird?

  • None of the solutions is ok? – enzotib Jun 26 '11 at 17:44

At this web site you can find a non official thunderbird extension to use an external editor of your choice:


  • 2
    Note from the future: This extension doesn't appear to work with newer versions. – Nich Del Jun 24 '16 at 18:43
  • @NichDel it works, see the answer below (i.e. about adding the toolbar). – Hi-Angel Feb 28 '17 at 2:31

As enzotib stated, you should use the external editor plugin.

The direct link to the plugin should be this: http://globs.org/file/exteditor_v090.xpi

You'll need to download the plugin, then go to Thunderbird and do: Tools -> Add-ons -> Install Add-on from file (from drop-down at top-right)

Then, you will need to set the preferences for the plugin so the external editor is gVim. On linux, that will probably just be 'gvim -f'.

Most importantly, you will then need to add the 'External Editor' button to your toolbar. Without adding the toolbar button the plugin would not work for me. Below I included a picture where you can see the 'External Editor' button that I'm referring to. After adding the toolbar button, you can launch the external editor with the toolbar button or CTRL-E

enter image description here


Try Teledactyl. You can do much more vim-oriented things with it but if you're only interested in editing files in vim, it also works, just disable all of it and keep the external editor feature on.

This is what I had (use GMail interface now) in my .teledactylrc file:

:set editor='gvim -S .vimrcforvimperator -f'

I think you should use this tutorial to solve your problem.

Link Here: http://blog.geekq.net/2010/05/13/vim-external-editor-thunderbird-3-ubuntu/

  • that tutorial assumes that vim is being used as the external editor, not gvim (which the asker wants to use). Would this still work fine, or what changes would be necessary? – Christopher Kyle Horton Jun 26 '11 at 4:53
  • Here on my computer, no changes were necessary. :D – vhbsouza Jun 28 '11 at 2:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.