1

I installed Lubuntu 13.10, and I'm observing a different behavior of xmodmap than in previous versions. I have a ~/.Xmodmap file that maps the Caps Lock key to the Ctrl key. Executing modmap ~/.Xmodmap works as expected. However, the .Xmodmap file is ignored during the login process. In another machine with Lubuntu 13.04 the .Xmodmap is read automatically during the login process.

I tried adding a line to /home/ajw/.config/lxsession/Lubuntu/autostart that call a script that set the xmodmap, but this is ignored.

According to this link, somewhere during the login process the xmodmap setting is undo by a call to setxkbmap.

Any idea about how to set xmodmap automatically in Lubuntu 13.10?

0

I had similar problems using Ubuntu, but I solved them using the sleep command. This way any other processes won't undo my Xmodmap.

My startup command: sh -c 'sleep 2 && /usr/bin/xmodmap /home/username/.Xmodmap'

And this (How to add startup applications in lubuntu?) might help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.