3

Recently I installed ubuntu 13.10 on my new Lenovo U430 Touch alongside windows 8.1

Now wifi keeps dropping every few mins, I disable and enable wifi and then it works again, but dropped after a few mins again.

I checked many forums and none of the suggestions seem to work. This problem does not happen on win 8 though.

Here is the output of

sudo lspci -nnk | grep -B4 Network
    Subsystem: Lenovo Device [17aa:3978]
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
    Subsystem: Lenovo Device [17aa:3801]
    Kernel driver in use: r8169
02:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b2] (rev 73)

and the output of

 dmesg | tail -n 50 

as soon as the wifi stopped

[ 6493.935237] WARNING: CPU: 0 PID: 6423 at /build/buildd/linux-3.11.0/net/mac80211/util.c:1538 ieee80211_reconfig+0x1234/0x13f0 [mac80211]()
[ 6493.935240] Modules linked in: hid_generic hid_multitouch uvcvideo videobuf2_vmalloc videobuf2_memops usbhid videobuf2_core videodev hid btusb parport_pc(F) ppdev(F) bnep rfcomm bluetooth snd_hda_codec_hdmi snd_hda_codec_realtek joydev(F) arc4(F) x86_pkg_temp_thermal coretemp kvm(F) nls_iso8859_1(F) crct10dif_pclmul(F) crc32_pclmul(F) ghash_clmulni_intel(F) aesni_intel(F) aes_x86_64(F) lrw(F) gf128mul(F) glue_helper(F) ablk_helper(F) cryptd(F) iwlmvm mac80211 snd_hda_intel iwlwifi snd_hda_codec snd_hwdep(F) snd_pcm(F) cfg80211 snd_page_alloc(F) i915 snd_seq_midi(F) microcode(F) snd_seq_midi_event(F) psmouse(F) snd_rawmidi(F) snd_seq(F) serio_raw(F) snd_seq_device(F) drm_kms_helper wmi snd_timer(F) drm ideapad_laptop sparse_keymap snd(F) lpc_ich i2c_algo_bit mei_me mei soundcore(F) video(F) intel_smartconnect mac_hid lp(F) parport(F) ext2(F) ahci(F) libahci(F) r8169 mii(F)
[ 6493.935362] CPU: 0 PID: 6423 Comm: kworker/0:4 Tainted: GF       W    3.11.0-13-generic #20-Ubuntu
[ 6493.935365] Hardware name: LENOVO 20270/Cherry 4A Touch, BIOS 7CCN32WW 09/04/2013
[ 6493.935380] Workqueue: events ieee80211_restart_work [mac80211]
[ 6493.935382]  0000000000000009 ffff880008e69d40 ffffffff816e54ba 0000000000000000
[ 6493.935401]  ffff880008e69d78 ffffffff81061dbd ffff880158b8e800 0000000000000003
[ 6493.935407]  00000000ffffffea ffff880157498600 0000000000000004 ffff880008e69d88
[ 6493.935413] Call Trace:
[ 6493.935419]  [] dump_stack+0x45/0x56
[ 6493.935427]  [] warn_slowpath_common+0x7d/0xa0
[ 6493.935454]  [] warn_slowpath_null+0x1a/0x20
[ 6493.935474]  [] ieee80211_reconfig+0x1234/0x13f0 [mac80211]
[ 6493.935492]  [] ieee80211_restart_work+0x87/0xa0 [mac80211]
[ 6493.935509]  [] process_one_work+0x17c/0x430
[ 6493.935514]  [] worker_thread+0x11c/0x3c0
[ 6493.935520]  [] ? manage_workers.isra.24+0x2a0/0x2a0
[ 6493.935528]  [] kthread+0xc0/0xd0
[ 6493.935549]  [] ? kthread_create_on_node+0x120/0x120
[ 6493.935554]  [] ret_from_fork+0x7c/0xb0
[ 6493.935561]  [] ? kthread_create_on_node+0x120/0x120

Appreciate help in resolving it.

PS. I am a new user for ubuntu and have added the details I seem to think might help identify the problem.

  • Have you tried to connect to another wifi and see if the problem persist? – Blaze Tama Nov 22 '13 at 5:16
  • I believe the problem is there when I do not use the wifi for like 2 mins, I was on a unsecured network this afternoon for almost 30 mins but I was downloading a bigger file and did not have that problem. I can test later on a different network and post the results. However win 8 on the same laptop works on this same network, my phone, 2 other home computers, my home tv all uses the same wifi no problems. – rrag Nov 22 '13 at 5:39
  • Have you tried to reset your router? Turn it off, wait at least 10 seconds, and turn it on again. Sometimes this reset fix some strange problems. – Blaze Tama Nov 22 '13 at 5:41
  • 1
    I hate to say this, but it does work, got to give it to you, I feel stupid after this fix. – rrag Nov 22 '13 at 6:16
  • 2
    I don't have the reputation to comment so I will formulate my comment as an answer to Luca's question about drivers for the centrino 7260. I had the same problems with frequent wifi drops. The proposed answer from this Thread of restarting the router did not help. I ended up installing a new kernel version 3.12 based on this HowTo. However, they do warn you that installing the new kernel might result in problems. But it work – Ben K. Dec 14 '13 at 9:43
0

Ehm..i dont know how to explain this BUT...

  1. Turn off your router.
  2. Wait at least 10 secs.
  3. Turn it on again.

Or, the short answer : just restart your router, it might saved you from a lot of strange problems :D

2

I think that this is only a workaround. I have a Lenovo U430 too, with the Centrino wireless 7260 wireless card and I have the same problem. Wireless connection works on Ubuntu 13.10 out-of-the-box but about every 10 minutes the connection is lost. By resetting it with the network manager (disable and re-enable) the wifi works again, at least for another 10 mins.

Have you some tips about 7260 driver? As previously said, Ubuntu 13.10 uses 3.11.0-13-generic kernel..

Thanks, Luca

  • This is both an answer and a question. Add the question part as a comment to the original question. – Luís de Sousa Nov 24 '13 at 14:47
  • Just to report back my experience. Even with kernel 3.13 the wireless connection still was unstable. I managed to change the wireless board with another one in the Lenovo whitelist [link] (download.lenovo.com/consumer/mobiles_pub/…) pag 76). It is a BCM943228HMB mini PCI-e available on Amazon. The connection now is stable and the signal quality better then before. I hope it might help – luca May 23 '16 at 11:26
1

As updated in a comment, updating the Kernel fixed the problem.

I have a Lenovo u530 - 7260 wireless driver.

modinfo iwlwifi | grep -e 7260 -e version
version:        in-tree:
firmware:       iwlwifi-7260-7.ucode
srcversion:     A3081EB36A8BAE67C8037E0
vermagic:       3.12.0-031200-generic SMP mod_unload modversions

Not the answer you're looking for? Browse other questions tagged or ask your own question.