There are plenty of threads on this topic, I've tried every solution mentioned there:

  1. Different version of Ubuntu (Kubuntu 13.10, Kubuntu 12.04, Ubuntu 12.04)
  2. Using USB 2.0 and USB 3.0 ports
  3. Different Live USB creation software (Linux Live USB Creator, unetbootin, Universal USB Installer, Kubuntu Startup Disk Creator)
  4. Switching from IDE to ACHI
  5. UEFI and legacy boot
  6. Disabling secure boot.
  7. Replacing "quiet splash" with "nomodeset" in GRUB
  8. Plugging out hard disk
  9. Using different USB drives (regular USB stick, external USB HDD)

But I still get the same error every time. No difference.

My PC is a brand new computer, all systems are functioning well (I tried to install Windows 8, it works just fine).

  • Motherboard: GA-970A-DS3P
  • CPU: AMD Phenom II X4 970
  • Graphic adaptor: AMD Radeon HD 5770 (Vapor-X)

What to try next? Please help me prove to my husband that Ubuntu can be installed everywhere, I am out of ideas.

  • Looks like you tried everything! You may have to fall back to try installing from CD-ROM. – Humpity Jan 19 '14 at 0:27

Having the same problem, on the same mobo, all I can suggest is contacting gigabyte support (which I've done, and am waiting for a response from). However, I'm not that hopeful of a useful answer, given that after submitting the ticket, they showed me a page highlighting the OS support being Windows only (though they also give some guidance on the same support list for using Linux, advising 3rd-party drivers).

Maybe we can hope for a BIOS upgrade. I didn't put an optical drive is the computer, so I'll have to burn the disk on my other computer, then take the drive out and transplant it, and so on... a real drag.

I'm also trying each non-USB3.0 (as I know there are reasons that wouldn't work) socket. So far I've tried the two front-panel ones that I have.

I'll update here if I either get anywhere with that, or get a useful response from support.

UPDATE: So, I managed to get it to boot from optical with working networking and USB! The same trick might work to get the USB stick to boot, given as it's probably the wonky USB that causes that problem. In BIOS Setup, make sure the IOMMU controller is set to off, and when GRUB comes up, edit the boot commands, and add the following to the kernel parameters: iommu=soft

I got this from the Ubuntu forums, at http://ubuntuforums.org/showthread.php?t=2114055&page=2

| improve this answer | |
  • Gigabyte support offered me a beta BIOS update, but that didn't change anything. Last response from them indicated that they aren't likely to do more as they don't support Linux. I politely suggested that it might be in their interests to avoid a product being known as not working properly with Linux; I've gotten a cheap DVD drive, though, so I'm going to solve it by using a disc. – SamBC Jan 29 '14 at 21:30
  • Interesting results booting from optical to install... no joy on any USB device connected to a USB 2.0 port. Networking doesn't seem to be playing either, though I'm going to fiddle with that. – SamBC Jan 30 '14 at 19:44

I solved this problem other way. However, thank you for your answer.

When installing Ubuntu I turned on emulation of USB as CD-Rom (I do not have CD-Rom). This solved the problem above. There was no any errors.

Because I have two OS (Windiws 8.1 and Xubuntu 13.10) another error appeared. It was: ‘grub-efi-amd64.efi can’t be installed on /target/’ error as usual. Solution can be found here

For boot-repair I again turned on emulation of USB as CD-Rom, also I enabled IOMMU.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.