(Warning: typed on an iPod touch)

I downloaded 13.10 (from 13.04) today as recommended by the software updater. I left it to download for a couple hours (it said at the beginning it should 41 minutes with my connection) and came back and it wasn't done and showed no progress for quite awhile.

I continued browsing the internet (videos didn't work because of a lack of flash). I noticed the top icon (I think it's called system launcher) didn't have it's picture and tried clicking it to go to the terminal. As soon as I clicked on it, the side bar with app and top bar disappeared (the wallpaper was visible) but Chromium was still working. I thought the installer was close to restarting so after leaving the screen like that for awhile.

I did a hard restart (hold power button). Tried starting it back up and can't remember what came up first (I've been reading and trying advice on similar problems) but it didn't start right up to 13.10. (I think I had accidentally started the guest account a while before if that makes any difference)

When I start it up, it goes to GNU GRUB version 2.00-13ubuntu3 with the options:

  • Ubuntu
  • Advanced options for Ubuntu
  • Memory test (memtest86+)
  • Memory test (memtest86+, serial console 115200)

and at the bottom it says Use the [up] and [down] keys to select the highlighted entry. Press enter to boot the selected OS, 'e' to edit the commands before booting or 'c' for a command-line.

When I select the "Ubuntu" option, I get:

File system check or mount failed.
A maintenance shell will terminate this shell and continue booting after 
re-trying file systems. Any further errors will be ignored.
root@[my name]-G41M-ES2L:~#

and nothing happens when I press any key.

On other threads, they talked about booting in recovery mode by going to Advanced options for Ubuntu > Ubuntu with Linux 3.8.0-33-generic (recovery mode).

When I do that, some code scrolls through the screen for a few seconds and then a recovery menu pops up.

Recovery Menu (filesystem state: read only)
        resume         Resume normal boot
        clean             Try to make free space
        dpkg              Repair broken packages
        failsafex         Run in failsafe graphic mode
        fsck                Check in al file systems
        grub               Update grub bootloader
        network          Enable networking 
        root                Drop to root shell prompt
        system-summary       System summary

                <OK>                 "

On the threads, they recommended people select the Drop to root shell prompt. When I select it, I get:

root@[my name]-G41M-ES2L:~#

How I can get my computer to boot without wiping my hard drive and starting over ?

I really appreciate taking your time to help me.

  • You seem to have restarted your PC at the wrong moment, when it was still busy doing something. Have you tried selecting 'Resume normal boot' ? – Ninad Nov 21 '13 at 9:09
  • @ninad116 when I select "resume normal boot", I does exactly what happens if I just select "Ubuntu" from the main GNU GRUB page. – carmatt95 Nov 21 '13 at 23:26

You can boot your Ubuntu in recovery mode by following instructions on Recovery Mode - Ubuntu Wiki. It is recommended that you read through this page entirely before proceeding.

Just to give you a gist of the steps to follow in your case,

  1. Enable networking in the same menu.
  2. Select Drop to root shell prompt
  3. Run command

    $ mount -o remount,rw /

    This will mount your partitions in Read / Write mode to boot from.

  4. Just in case, if you have /home, /boot, /tmp, or any other mount point on a separate partition, you can mount them with the command

    $ mount --all

  5. Run following command to repair broken packages that were damaged due to untimely reboot.

    $ dpkg --configure -a

  6. To remount partitions back in read-only mode, run $ mount -o remount,ro /

    (If system says "/ is busy", skip to step 8.

  7. Run $ sync
  8. Run $ reboot to restart your PC.

Do let me know how it goes.

Source : Patrick's and Scott's answers.

Once you have successfully got access to your old Ubuntu, for upgrading to 13.10, I will recommend that you download Ubuntu 13.10 ISO and create a LiveUSB to boot from.

This will ensure that Ubuntu 13.10 download and upgrade does not eat your bandwidth while browsing. You will also have an additional option of Try Ubuntu and other cool tools that come along with a LiveUSB setup.

| improve this answer | |
  • Thanks for your reply @ninad116 when I type in the "mount -o remount,rw /" and "mount --all" command, nothing happens. – carmatt95 Nov 22 '13 at 7:59
  • 1
    @carmatt95 I have updated the answer with next steps to follow. Pls refer to them and let me know the progress. – Ninad Nov 22 '13 at 21:02
  • It worked! Thank you so much! Can you recommend a site for learning the ins and outs of Ubuntu. I want to learn more of the code aspect. – carmatt95 Nov 23 '13 at 1:28
  • Glad to know that it worked for you. For learning purposes, you may refer to Ubuntu Forums. Moreover, Ask Ubuntu has always proved to be an insightful learning experience for me. Happy learning! – Ninad Nov 23 '13 at 6:35

I had almost the same problem. My PC went off while upgrading and then it didn't boot;

I solved it by: Recovering the Ubuntu; Installing the 13.10 again and repairing/restarting the Unity (you can find in this forum relevant issues).

| improve this answer | |
  • how do you "Recovering the Ubuntu; Installing the 13.10 again and repairing/restarting the Unity (you can find in this forum relevant issues)." I tried finding a thread but couldn't find anything. – carmatt95 Nov 21 '13 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.