1

I'm having a very tough time dual booting with Ubuntu 13.10/OS X Mavericks on my Macbook Pro 8,2. Before this is closed as a duplicate, I've tried all popular solutions I could find to no avail, hopefully someone may be able to point out the error of my ways.

Problem: rEFIt's gpt sync tool, as well as gptsync 0.14-2 both report "GPT partition of type 'Unknown' found, will not touch this disk", even after following the recommended(1) solution found in this post.

Steps I follow (hopefully someone can recognize one of these as incorrect):

  • Installed rEFIt from .pkg. Reboot/Login to mac twice. rEFIt menu seen second time.
  • Created 2nd Mac OS X Journaled Filesystem with Disk Utility, while shrinking the original.
  • Reboot into Ubuntu installer and start the installer's partition tool.
  • Delete 2nd Mac partition. Create ext4 partition /dev/sda3 taking up all but 2GB of remaining space.
  • Create /dev/sda4 swap with remaining 2GB
  • Choose /dev/sda3 for bootloader installer (can someone confirm this is correct? I've seen a lot of conflicting opinions. Other option being /dev/sda, which I understand to be NOT what you should do since it will break OS X boot)
  • Run installer and reboot. Tux shows up in the menu, but freezes on load when choosing this option.
  • Try to run the rEFIt sync tool, and the MBR looks correct, recognizing /dev/sda3 as as Linux Partition, but /dev/sda3 is *Unknown* in GPT.

At this point I'm pretty much I'm at a loss. I attempted running the gptsync script recommended in the solution above to no avail. In addtion, I've tried manually rebuilding the hybrid MBR with gdisk on the Mac side (2), but again - MBR looks fine, GPT has /dev/sda3 as *Unkown*. Running the Tux option from rEFIt after this option actually pulls up a grub recovery console, but it says it's missing the filesystem.

Could anyone steer me in the right direction? Should I be using a different partitioning tool? Where should the linux bootloader be installed?

(1) I'd link to this, but I don't have 10 reputation. Found here: help.ubuntu.com/community/MactelSupportTeam/AppleIntelInstallation

(2) ubuntuforums.org/showthread.php?t=1810275&page=19&p=11215214#post11215214

1

I have a number of comments/observations and questions:

  • rEFIt is abandonware, and along with it, its version of gptsync. I've forked rEFIt as rEFInd, and recent versions include an updated version of gptsync (as an EFI application; it doesn't currently work when compiled as a Linux application). To use my gptsync in rEFInd, though, you must both install the gptsync_{arch}.efi program file and edit the showtools line in refind.conf to enable the gptsync option. This hoop-jumping is deliberate for the following reason:
  • Hybrid MBRs, which is what gptsync creates, are flaky and dangerous. It's best to avoid them unless you need them, which on a Mac you do need in order to boot in BIOS/CSM/legacy mode. You also need them to boot Windows on a Mac, except for Windows 8 on some models, and Windows 7 if you jump through a lot of hoops. There are alternatives to a BIOS/CSM/legacy-mode boot, though....
  • Although booting in BIOS/CSM/legacy mode is sometimes necessary, it's often better to boot Linux in EFI mode. In fact, this is one of the reasons I created rEFInd; it can boot a Linux kernel (version 3.3.0 or later) in EFI mode without using GRUB or any other boot loader. You'll need to have an EFI filesystem driver for whatever filesystem holds your kernel, though. (Several come with rEFInd.) Alternatively, you can install any other EFI boot loader you like to boot in EFI mode rather than in BIOS/CSM/legacy mode.
  • Could you elaborate on your statement that "Tux shows up in the menu, but freezes on load when choosing this option?" Are you referring to the rEFIt menu or some other menu? When you select the option, does anything happen before the freeze -- for instance, do you see a GRUB menu, does the screen change color, or do you see any text (even briefly)? Details such as these are vital for diagnosing problems.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.