109

I had a nice GUI for changing startup applications (after logging in) on GNOME 2. How can I start that application on GNOME 3?

Where can I download it? What is the package name? What command is used to launch it? I have Pidgin still launching on start, but I have converted back to Empathy, so I would like to know how I can remove Pidgin and start Empathy instead.

8 Answers 8

135

From terminal or Alt+F2 dialog run: gnome-session-properties.

For newer ( 3.14+ ) versions of Gnome just use the Tweak Tool from the applications menu.

6
  • 4
    well no longer works in gnome 3.14 :( May 25, 2015 at 9:10
  • 7
    @TummalaDhanvi as per askubuntu.com/a/645919/293889 gnome-tweak-tool works
    – Andy
    Sep 14, 2015 at 22:34
  • @Andy Which version of gnome are you on Sep 19, 2015 at 3:16
  • 2
    Works for me on Ubuntu GNOME 16.04 (GNOME 3.18).
    – Spotlight
    Dec 18, 2015 at 21:38
  • 2
    Both gnome-session-properties and gnome-tweak-tool are available in Gnome 3.18.5 on Ubuntu 16.04. The gnome-session-properties seems more flexible, as it lets you enter a command line instead of just choosing a program from a curated list.
    – ntc2
    Dec 27, 2016 at 23:06
70

None of the other solutions worked for me in GNOME 3.14 on Ubuntu GNOME 14.10. What finally worked, was creating .desktop files by hand.

First, create the ~/.config/autostart/ folder, if it doesn't exist.

Then, create a ~/.config/autostart/my-app-to-startup.desktop file for each program you want to start on login.

For example, here's what my ~/.config/autostart/pidgin.desktop file looks like:

[Desktop Entry]
Type=Application
Exec=pidgin
Hidden=false
X-GNOME-Autostart-enabled=true
Name=pidgin
Comment=instant messenging client

Here is the specification for the keys you can place in those .desktop files. This puts some context to that specification as to how it applies to startup applications as well as some exceptions to those rules. Credit for this solution goes to this Linux and Friends site.

4
  • linuxandfriends.com does not exist anymore, seemingly.
    – Déjà vu
    Oct 26, 2017 at 9:46
  • 1
    My autostart on raspian worked for at least 1 year and then suddenly wouldn't work any more. I added your X-GNOME-Autostart-enabled=true, which was missing in the config created originaly by the GUI and now it autostarts again. GNOME and Co. are such horrible projects when it comes to backwards compatibility. Hope this helps!
    – user643011
    May 14, 2019 at 10:58
  • This works! I first tried putting the command (xbindkeys) in .xprofile, .xsessionrc and .gnomerc, which didn't work; are these files all deprecated?
    – BlackShift
    Apr 17, 2021 at 9:03
  • Moving the .desktop file to ~/.config/autostart/ was the missing piece of the puzzle in my case (Gnome 3.38.5). Adding X-GNOME-Autostart-enabled=true was not required. Jan 6 at 6:47
20

As rossouwap's answer is not working any more on Gnome 3.14+ now you should type Alt + F2 then run gnome-tweak-tool on the dialog and then look for the tab Startup Applications.

EDIT
I assume you have Gnome Tweak Tool installed. If not, run this on the console:
sudo apt-get install gnome-tweak-tool

4
  • 1
    Unfortunately, there does not appear to be a way specify which arguments to launch any given startup application with. Am I missing something? Aug 21, 2015 at 4:16
  • @Wallacoloo if it is, then I didn't find it neither Aug 21, 2015 at 10:12
  • if "gnome-tweaks" does not seem useful, click the < button which should switch the panel to a list that contains "startup applications"
    – Jasen
    Apr 24 at 1:22
  • @Ponkadoodle arguments have to be baked into the launcher. you need to make the launcher first, and then add the launcher to startup applications. Use alacarte (display name: "main menu") to make the launcher.
    – Jasen
    Apr 24 at 1:31
7

I had a nice GUI for changing startup applications (after logging in) on GNOME 2. How can I start that application on GNOME 3?

The answer is simple. You still have nice GUI in your system, only in Gnome 3 is set up to be hidden, don't ask me why. Here's how you bring it back:

Open a terminal and copy/paste the following code:

gksu gedit /usr/share/applications/session-properties.desktop

Look for the line that says NoDisplay=true and change it to NoDisplay=false (or delete the line altogether if you prefer).

3
  • 2
    It seems like a lot of things in Gnome 3 are still half-baked...
    – John
    Jan 13, 2014 at 18:09
  • Hmm - that file doesn't even exist on my distro (not ubuntu but FC19) Sep 29, 2014 at 13:41
  • That file (nor anything with a similar name to it) does not exist for me either on Arch / Gnome 3.16.3. Aug 21, 2015 at 4:14
3

There's no handy tool to do it in GNOME 3, so you can create a .desktop file manually or use this app.

2
  • 1
    It would be nice if you disclose your affiliation with the app you linked to.
    – edwinksl
    Aug 18, 2016 at 9:49
  • @edwinksl, yes, it's my app. I couldn't find a tool with GUI to manage autostart in GNOME3, so I decided to make it :)
    – hant0508
    Aug 18, 2016 at 19:25
1

ubuntu groovy

gnome-shell --version
GNOME Shell 3.38.1

Activities search

and

startup applications

1
  • This method, besides it's the gnome default, is horrible, you need to manually insert the command or app path. Would be nice to have an selector like gnome tweak tool has, from your gnome launcher list Dec 20, 2021 at 16:22
-2

If you have GNOME 3.6+, you can install this extension which adds a shortcut to the system menu:

https://extensions.gnome.org/extension/620/startup-applications/

-4
  1. To access System Settings, click the "Power" icon at the top right corner of the desktop and select "Sytem Settings". Under the "Personal" heading, click on "Startup Applications." This is the same GUI from previous versions of Ubuntu and Gnome.

    系统设置开始

  2. To remove Pidgin from your Startup Applications, click on the row that says "Pidgin" in the list. Then, click the "Remove" button on the right, which will remove the entry altogether. Alternatively, you can disable the program from starting when you log in by simply unchecking the checkbox on the far left. This would allow you to re-check the box in the future, to re-enable Pidgin as a Startup Application.

    启用开始

  3. To add Empathy to your Startup Applications, click the "Add" button. Choose a Name, such as "Empathy". It can be anything you like. Next to Command, type empathy. This will launch an Empathy window after you log in. If you would prefer to have Empathy start hidden in the Messaging Menu, enter the command empathy -h instead. Next to Comment, you can leave blank or you can add a descriptive comment. Then click Add.

    Empathy开始

3
  • 6
    I dont have startup Applications there.
    – Riki137
    May 2, 2011 at 20:55
  • Well that a unity DE not gnome at all May 25, 2015 at 13:21
  • 1
    Screenshots in Chinese is not useful in Stack Nov 19, 2018 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.