This is what I did:

  • Pressed Ctrl+Alt+F1

  • Stopped lightdm and all that stuff

  • Removed nouveau driver and installed Nvidia 331.20 driver

Since then after loging in my computer I get a black screen and I can only get to the place where you log in and press Ctrl+Alt+F1


3 Answers 3


The source of the problem probably starts with installing the 331 driver from the .run file provided by NVIDIA.

Here are the steps that worked for me and resolved both this and the low-graphics mode problem that subsequently came up.

Remove Nvidia proprietary drivers:

sudo apt-get remove --purge nvidia*

Add xorg edgers PPA for NVIDIA drivers and install nvidia-331:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-331

Remove/purge bumblebee and reboot:

sudo apt-get --purge remove bumblebee
sudo reboot

The following helped:

  • 5
    Removing the bumblebee did the trick! Many thanks. Resolved...(sigh)... another 2-hour torture session of dealing with video drivers on Linux. I'm guessing the reason this is so poorly managed is that canonical devs are preoccupied much more with building up Mir's pipeline then dealing with the Xorg pipeline. Driver install should resolve all these problems automatically (which would be easy to implement). Feb 7, 2014 at 21:29
  • 1
    You last link explains it all: bumblebee is blacklisting all nvidia drivers... :-/
    – Joël
    Feb 13, 2014 at 17:42
  • This fix just saved my day, thanks for the help!
    – euDennis
    Feb 22, 2014 at 21:48

I was stuck in a similar situation. I removed all Nvidia drivers and associated programs and then manually re-installed the drivers from terminal mode. I believe, in my case, that an unknown Nvidia program conflicted with the Nvidia upgrade (3.19). With the screen black you will need to use terminal mode CTRL+ALT+FI to conduct all your work.

In my case, the initial re-boot "failed" after installing the updated driver (3.19), but I shut-down and rebooted and everything worked. What I have heard (unverified) is that the Nvidia graphic card is not immediately recognized by the computer when booting, hence initial failure.

I did a quick check and ran across this website: Nvidia Driver 331.20 released, Install it in Ubuntu & Linux Mint. It may prove helpful.

This may prove helpful too: Install NVIDIA GeForce driver in Ubuntu 13.10 / 13.04 / 12.10 / 12.04 using PPA

How to change proprietary video driver using the command line?

Also read the following: Reset Unity and Gnome to default values [duplicate] and How To Reset Unity And Compiz In Ubuntu 13.10 Or 13.04. I found them useful too.


long shot but if you are using UEFI boot, just enable support for legacy boot in BIOS (do not fallback to it from UEFI) and see if you can get it to work (weird I know)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.