13

I have a 17" laptop with 1600x900 resolution, but it's not enough to open windows side by side. I'm wondering if i could zoom out (or any other solution) windows (or the whole desktop). Is there a solution on xserver or on the WM to make this happen?

By the way, compiz zoom out plugin don't let you to zoom out more than 1:1 which is not enough, I want to zoom out more the same way as spreading all windows with unity-tweak-tool.

21

Disclaimer: I do not know if it works for all graphic drivers. Intel driver here, in 13.04.

First of all get the normal screen you have active:

xrandr --current

My output is:

Screen 0: minimum 320 x 200, current 1024 x 600, maximum 32767 x 32767
LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 220mm x 129mm
   1024x600       60.0*+   65.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)

Ok, it is LVDS1. Now for example to zoom out at half linear dimension:

xrandr --output LVDS1 --scale 2x2 

The whole screen should zoom out. Now I have:

(0)asus-romano:~/research/reviews% xrandr --current
Screen 0: minimum 320 x 200, current 2048 x 1200, maximum 32767 x 32767
LVDS1 connected 2048x1200+0+0 (normal left inverted right x axis y axis) 220mm x 129mm
   1024x600       60.0*+   65.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)

So the systems thinks it has a 2048x1200 screen. Very useful for crappy programs that thinks you have a gazillion pixel space and do not offer scrollbars in some option windows...

To go back:

xrandr --output LVDS1 --scale 1x1

(You can use 1.5x1.5, too). Look at man xrandr for a lot of fancy things.

Oops. There seem to be a bug in which the extended video zone is not reachable: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/883319 and upstream https://bugs.freedesktop.org/show_bug.cgi?id=39949

A workaround for this is to specify the desired larger area as a --panning option, e.g.:

 xrandr --output LVDS1 --scale 2x2 --panning 2048x1200

It will not cause any actual panning, since the whole large area fits on the screen due to the scaling.

| improve this answer | |
  • it almost works OK, but i need to move the cursor around.i know that my screen specification can't do more than that. but, I'm searching for a solution to bypass them by removing some pixels from the frame the same way when zooming out photos so i can see the whole desktop on my screen – user212807 Dec 12 '13 at 23:54
  • Yep --- I see. The zone where the mouse can go is limited to the original desktop (strange). Maybe is time for another question... – Rmano Dec 13 '13 at 0:53
  • OK --- seems a bug. I linked the two most probable culprits. – Rmano Dec 13 '13 at 1:04
  • "First of all get the normal screen you have active: " ­— uh, how? :-) – Christopher Done Apr 3 '14 at 17:39
  • @ChristopherDone: ok, missing the xrandr line. – Rmano Apr 3 '14 at 17:46
0

There is an option of scaling out the desktop upto 1:4 and scaling in upto 1:0.5. This option is available in System settings -> Display. However, this is not in a very good shape at the moment, have seen issues where it breaks unity.

So this is recommended only if its absolutely necessary and other solutions don't work out.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.