I just installed my new computer (Gainward Z87X-UD4H, i7-4770, no video card). Due to some gaming, I installed Windows 7 first. Afterwards I installed Ubuntu 12.04 LTS. Now, my Ubuntu starts without any problems. Choosing Windows in grub, it hangs on grub's purple screen.

Again, this is not about a purple screen for Linux (for example, My computer boots to a black screen, what options do I have to fix it?), it's more related to this, this or this. How I can debug/fix that?

For the protocol, I tried:


You can try booting the windows install image/recovery disk and manually recovering the boot EFIs (with the bootrec and bcdboot commands).

Here is a complete guide: https://superuser.com/a/504360/275127 Helped me a lot when this happened to me.

When doing the above mentioned procedure, you should find a folder, on your EFI partition, with an "ubuntu" folder that hosts the ubuntu boot files. Create by following that post's guidelines the windows EFI files in a separate "microsoft" folder next to the "ubuntu" one.

Reboot, boot ubuntu normally, fire up boot-repair. Boot-repair will detect your new windows EFI files and proceed to add them to GRUB (the recommended settings option should suffice). If Boot-Repair asks if you want to back-up the windows EFI files, say yes.

I hope this helps.

  • I don't use UEFI and Windows 8. My BIOS is configured on "Legacy only". – Dennis Nov 19 '13 at 0:28
  • Huh. I would've asked before posting my answer but I don't have comment privileges. Well, I presume you could try the same procedure. I don't really know how do the ubuntu boot files set up during install in legacy mode, but you could still try recovering the windows boot. At least then you could use EasyBCD and then Live CD an ubuntu, install repair-boot and repair your grub. Here is a guide on recovering the windows boot. neosmart.net/wiki/recovering-windows-bootloader – Anglepoise Nov 19 '13 at 0:40
  • I ran /fixmbr, /fixboot and /rebuildbcd with bootrec.exe. Afterwards Windows was starting again. Then I did the boot-repair.Now I am back to my initial issue: Windows hangs at the purple screen. – Dennis Nov 19 '13 at 1:38
  • Did you run boot-repair again? Sounds like a grub problem. Grub loads ok? – Anglepoise Nov 19 '13 at 7:59
  • Yes, I ran boot-repair again. Grub loads ok. Ubuntu as well. – Dennis Nov 19 '13 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.