3

I am using Lubuntu and I can't find any GUI for screensaver settings. I am missing something ?

Lubuntu 13.10 .

2
  • 1
    Which version of Lubuntu is it?
    – Richard
    Nov 18 '13 at 20:51
  • Are you looking for xscreensaver-demo ?
    – tpv
    Dec 5 '13 at 23:43
8

What about this:

Menu>Preferences>Screensaver Preferences
1
  • It is indeed right. Since this is an answer, you should not post it as a comment. :) Sep 11 '14 at 22:08
0

Suggest you check in ~/.config/openbox/autostart.sh with your favorite text editor to see if it is launching xscreensaver.

If you can't launch xscreensaver, perhaps it was not installed; run apt-get install -y xscreensaver

4
  • There is no such directory on Lubuntu. Nov 18 '13 at 23:16
  • Are you using Lubuntu 13.10 ? Also, please try the apt-get install -y xscreensaver to make sure it's installed.
    – K7AAY
    Nov 18 '13 at 23:59
  • Yes, I am using 13.10, anyway how dows installing xscreensaver address my question of having a GUI for the screensaver setup ? Nov 19 '13 at 0:12
  • Openbox should be lowercased. Nov 6 '14 at 16:35
0

To check your current xset configuration, open the terminal and type this: xset q

You'll then be shown what's set. You can see there these which are the ones you want to change:

$ xset q
...
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
...
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

After you fallowed the instructions above, if again you type xset -q in the terminal, you'll see that now it has changed to:

$ xset q
...
Screen Saver:
  prefer blanking:  no    allow exposures:  yes
  timeout:  0    cycle:  600
...
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Disabled

So now you can see that there's no blanking, no timeout and DPMS is disabled.

In the future if you want to turn them on again, just go to Menu/Control Menu/Settings/Default Applications for LXSession->Autostart and remove all the xset commands you entered.

If during a session you want to turn on some of the settings that you disabled, just enter in the terminal the proper commands following.

  • enable blanking screensaver: xset s blank
  • ten minute interval: xset s 600 600
  • enable power management: xset +dpms

For more information you can type xset on the terminal and press Enter>, you'll be shown all the available options.


From here: http://lxle.net/forums/discussion/1463/disable-lockscreen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.