6

I'm using the very useful Supervisor. But I'd like to prevent it from running when I start ubuntu: is it possible ?

9

If it's a service (daemon) install rcconf:

sudo apt-get install rcconf

And then, run it and disable supervisor with it (uncheck its corresponding box, and accept):

sudo rcconf

Whenever you want to run it manually you can use the command:

sudo service supervidor start

sudo service supervidor stop
  • 1
    Haaa, great, thanks: I wasn't sure all services were managed the exact same way. Perhaps should I extend my question to How can I prevent a service to run at startup ? – Anto Nov 18 '13 at 14:43
  • There's plenty of such question, so yours would probably marked as duplicated. You can manage a lot of services with rcconf, just be sure you find out first what they do before you disable something critical. Glad it helped :) – animaletdesequia Nov 18 '13 at 14:44
  • Oh, ok. Anyway rcconf is a great tool, thanks a lot ! – Anto Nov 18 '13 at 14:53
  • 1
    Doesn't rcconf work only with SistemV-init style files? Probably in this case supervisor is in that category (otherwise it wouldn't work), but take into account that most of Ubuntu "services" are managed by upstart (see @drc's answer) – Rmano Nov 18 '13 at 15:18
  • To be honest I don't really know, but I would be really interested if you know some upstart manager equivalent to rcconf, I think bum (boot up manager) is one of them, but may it be a command line equivalent? Thanks! – animaletdesequia Nov 20 '13 at 13:37
6

There's probably a file for it in /etc/init/, probably called supervisord.conf which instructs upstart to start supervisord on boot.

The file will have the start conditions some close to the top, looking somewhat like this (taken from lightdm's init file):

start on ((filesystem
           and runlevel [!06]
           and started dbus
           and plymouth-ready)
          or runlevel PREVLEVEL=S)

Update: As mentioned in the comments, the usual way of disabling an upstart service is creating an override file for that service by issuing the following command:

echo 'manual' | sudo tee /etc/init/supervisord.override

You could also comment those lines using # and supervisord won't start automatically, but changes like that might be overwritten by a future update.

If there is no such file, supervisor might be using old, init-style configs in /etc/init.d/. If that's the case, you can disable it by running

update-rc.d -f supervisord remove

  • 3
    Correct, although the "standard" way to locally disable services at startup for upstart is sudo bash -c "echo 'manual' >> /etc/init/supervisord.override" (so that it will not be re-enabled by updates or similar events). – Rmano Nov 18 '13 at 15:14
  • 1
    You're correct, must have slipped my mind. I'll update my post accordingly. – drc Nov 18 '13 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.