9

I have a HP DeskJet 940c. It had always worked.

A few days ago it has suddenly stopped working. Even after reboot, its status ("Printer State") always shows "Stopped - Filter failed" and every time I try to print the job remains "pending" forever.

I have rebooted several times.

Is there any known fix/workaround?

5

I assume that the printer worked before. Check your /var/spool/cups directory, and empty it.

If that does not help, see the instructions for install the necessary plugins for your HP printer here.

| improve this answer | |
  • 1
    Yes it worked before as I said. After emptying /var/spool/cups, and reconnecting the printer, the issue persists. These errors appeared in /var/log/cups/error_log when I connected the printer: W [18/Nov/2013:19:35:59 +0100] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_hp W [18/Nov/2013:19:35:59 +0100] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_hp – matteo Nov 18 '13 at 18:39
  • 1
    Why should I suddenly need to install a plugin for a printer that was working? Just asking. Did I have the plugin and it got uninstalled or corrupted somehow? Is it some broken update that makes the printer need a plugin that it didn't use to need but doesn't either automatically install it nor issue a warning? – matteo Nov 18 '13 at 18:42
  • 4
    Ok, hp-setup fixed the issue. It created a new printer, I deleted the old one, and the new one works. Ridiculous. – matteo Nov 18 '13 at 18:49
  • For me this solution doesn't work – QkiZ Sep 14 '15 at 7:29
  • When using sudo hp-setup I had an error: "Printer queue setup failed". sudo hp-setup -i helped me. – user2513149 Aug 5 '17 at 9:38
2

Im my case, it was due to missing libraries as shown by cups error log fragment:

D [07/Apr/2014:18:42:50 -0300] [Job 6] /usr/lib/cups/filter/watermarkfilter: error while loading shared libraries: libcupsimage.so.2: cannot open shared object file: No such file or directory
D [07/Apr/2014:18:42:50 -0300] [Job 6] /usr/lib/cups/filter/rastertoprinterbin: error while loading shared libraries: libcupsimage.so.2: cannot open shared object file: No such file or directory

Pay attention if your printer driver is 32 or 64 bit, so you should install the right libraries arch.

| improve this answer | |
2

For me, the problem was solved by restarting the print server:

sudo systemctl restart cups.service
| improve this answer | |
2

This just happened to me out of the blue - yesterday the printer worked. I tried restarting the cups service, and tried restarting the machine, both didn't work. I'm on Ubuntu 16.04.6 LTS.

What worked for me:

I updated the installed software packages, after which the problem was gone.

apt-get update
apt-get upgrade
| improve this answer | |
1

In my case, one of my kids borrowed the USB cord. Ubuntu didn't seem to know this. After I uninstalled the printer driver, I noticed the cord missing. Replace cord and driver, now works fine

| improve this answer | |
1

For me, the problem happened because I had restarted the router and the IP address of the printer had changed. I went into the printer configuration in Ubuntu and updated the IP address (which I took from the printer's Network Summary printout) and it worked again after that.

| improve this answer | |
1

As proposed in the comments, removing the printer and adding it again worked for me.

I did empty the var/spool/cups directory before, but I don't know if this deletion had an impact. I didn't use the HP Device Manager.

| improve this answer | |
0

Removing the printer in system settings and re-installing it using the HP Device Manager fixed the problem for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.