2

After installing natty, my resolution is being set to 1024x768 instead of the proper 1368x768. The Monitors program doesn't allow me to set my resolution higher. I looked around for a solution, and I found instructions on using xrandr to set a new resolution:

xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr --addmode VGA1 1368x768_60.00
xrandr --output VGA1 --mode 1368x768

This worked (but it broke the top Unity panel). Now I need to find a way to automatically start the xrandr commands on boot. I edited /etc/gdm/Init/Default and ~/.xprofile, but neither worked.

What do I do? Can I stop the problem from happening in the first place?

2

This generally happens when the monitor doesn't report it's resolution correctly.

As you've found out, at runtime you can use the xrandr tool to add a correct mode and then switch to it. To make this permanent, you can edit /etc/X11/xorg.conf and add that mode as the preferred mode. I find the Debian XSF XRandR howto a good guide for editing XRandR settings in xorg.conf.

  • I don't have an xorg.conf, and I'm still not sure what exactly should I do. I followed some instructions elsewhere and tried generating one with sudo X -configure, but that didn't work. What should I do now? Sorry if I'm being dumb. – user15343 Apr 29 '11 at 16:18
0

Have you tried editing the file /etc/X11/xorg.conf ?

You can find many tutorials out there that explain how to add your own screen resolution in that file :

0

I also had the same problem and solved it after reading this document. Also you might want to check the question I posted at askubuntu.com and it's answers here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy