5

There exists a well-known bug in gnome-power-manager, which breaks Ubuntu on computers with 2 or more batteries. If one is empty, Ubuntu will shutdown ('critical battery'). As a workaround, it can useful to disable shutdown on critical battery status. However with Ubuntu 13.10 Saucy, the GUI doesn't allow this. What can I do?

  • I would hibernate and switch the batteries... – Alvar Nov 17 '13 at 17:03
  • I also found this useful in installing a new battery. – Hilton Shumway Jan 23 '15 at 6:31
11

Please install dconf-editor (sudo apt-get install dconf-editor) and go to

org gnome settings-daemon plugins power

Click the shutdown that is highlighted and choose "nothing" from the options as seen in this screenshot:

enter image description here

Please do be careful. If the 2nd battery runs out of juice be sure to shutdown yourself.

| improve this answer | |
0

Shutdown the system and dismount the empty battery. BTW, that bug was fixed 9 years ago. If you experience it again, then is obviously another bug.

| improve this answer | |
  • This bug was discussed 9 years ago (I feel old). I'm sure whether there was a valid solution. Of course, it's possible that todays bug is unrelated with similar symptoms. – Jan Nov 17 '13 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.