0

I have problem installing drivers for Asus wl-138g v2 card. First, after installing Ubuntu 12.04, I did everything that I could find with jockey-text or its GUI version. In the GUI version I got some error, generally discussed here:

Broadcom STA wireless driver

However, after executing apt-get install command which was a part of the answer there and installing also b43-fwcutter thingy I rebooted the PC and i had no longer the proprietary driver listed in the list though the wireless connection is still not available.

Then I wanted to install drivers from asus.com .

There was that readme file in which there was an instruction:

  1. Extract the tar package. tar -xzvf src-.tar.gz

  2. Build the Driver cd src/linuxsta/src/wl/linux in the makefile make sure to set the variables CROSS_COMPILE=, if the the gcc is not already in the $PATH or if a different compiler needs to be used, and GCC-REV= dictates the path of the prebuild regulatory binaries, to use while building the driver.(values it takes now are 3.4.2 or 4.0.2), if the kernel version is 2.6.14.3 the driver expects that iee80211_crypto.ko module be loaded, prior to loading this driver.

    make clean make

  3. Test the Driver by loading it insmod wl.ko

So I changed the Makefile so that:

GCC-REV:=4.6.2   //is that correct?
export CROSS_COMPILE :=/usr/bin/

And modified LINUXDIR to /usr/src/linux-headers-3.8.0-29-generic as it seemed to not find the Linux directory by its own. I got something like this:

   root@Bartek:home/bart/Downloads/src/linuxsta/src/wl/linux# make
Linux Directory is /usr/src/linux-headers-3.8.0-29-generic
Linux Kernel Versions is 3.8.0-29-generic
make -C /usr/src/linux-headers-3.8.0-29-generic CROSS_COMPILE=/usr/bin/ M=/home/bart/Downloads/src/linuxsta/src/wl/linux modules
make[1]: Entering directory `/usr/src/linux-headers-3.8.0-29-generic'
  CC [M]  /home/bart/Downloads/src/linuxsta/src/wl/linux/wlc_led.o
In file included from /home/bart/Downloads/src/linuxsta/src/wl/linux/wlc_led.c:17:0:
/home/bart/Downloads/src/linuxsta/src/wl/linux/../../include/typedefs.h:166:40: error: conflicting types for ‘bool’
include/linux/types.h:29:17: note: previous declaration of ‘bool’ was here
In file included from /home/bart/Downloads/src/linuxsta/src/wl/linux/../../include/linux_osl.h:21:0,
                 from /home/bart/Downloads/src/linuxsta/src/wl/linux/../../include/osl.h:24,
                 from /home/bart/Downloads/src/linuxsta/src/wl/linux/wlc_led.c:19:
/home/bart/Downloads/src/linuxsta/src/wl/linux/../../include/linuxver.h:19:26: fatal error: linux/config.h: No such file or directory
compilation terminated.
make[2]: *** [/home/bart/Downloads/src/linuxsta/src/wl/linux/wlc_led.o] Error 1
make[1]: *** [_module_/home/bart/Downloads/src/linuxsta/src/wl/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-29-generic'
make: *** [default] Error 2

I'm not sure what does it mean (problem with GCC? with drivers?). The PC is pretty old, year 2004, runs on AMD Sempron 3100+ with 2GB of RAM.

  • Are you quite certain the STA driver is correct for your device? May we see: lspci -nn -d 14e4: – chili555 Nov 17 '13 at 14:53
  • root@BARTEK:/home/bart/Downloads/src/linuxsta/src/wl/linux# lspci -nn -d 14e4: 00:06.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02) – bart Nov 17 '13 at 14:57
1

Please get a temporary wired ethernet connection, open a terminal and do:

sudo apt-get remove --purge bcmwl-kernel-source

If it isn't installed, that's fine, just continue:

sudo apt-get install linux-firmware-nonfree

After a reboot, your wireless should be working.

  • thank you.however, now it seems like something is wrong with rebooting. it hangs on the screen where it is written 'ubuntu' and 5 dots are changing its color from white to orange, but it doesn't seem to shut down completely in the end. – bart Nov 17 '13 at 15:29
  • Did it shut down eventually? Can you force a shutdown? After a reboot, is all well, wireless and otherwise? – chili555 Nov 17 '13 at 16:07
  • i had it being shutting down for like 40 minutes and i finally used the power button, after booting again the wireless finally worked and it seems like that now it is working well :) thank you for your assistance! – bart Nov 17 '13 at 16:21
  • Very happy to help. If your computer has trouble shutting down in the future, please feel free to ask a new question. – chili555 Nov 17 '13 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.