I recently ran into an issue on my Ubuntu 12.10 server that I can't seem to find a solution for. From my server I run a couple of Minecraft servers on different ports, usually to start the servers I would use the following command.

screen -S minecraft java -Xmx2048M -jar craftbukkit.jar nogui

There was never a problem until recently, as soon as I run the command it outputs

[screen is terminating]

No matter what privileges/account I'm under, sudo, root, a normal user, none of them. All return the same thing. I've tried rebooting the entire server, wiping all screens screen -wipe. I've also tried listing all the screens thinking that it would expose the screen that is still "terminating", but all it returns is No Sockets found in /var/run/screen/S-user.

What else can I do?

  • Are you sure this is a screen problem? Did you try running just the java command from a normal terminal (java -Xmx2048M -jar craftbukkit.jar nogui)? If that works, the problem is probably screen. But if it doesn't, then the problem lies elsewhere. – Malte Skoruppa Dec 16 '13 at 1:05


killall screen

This will kill all instances of it. Also be sure to try rebooting if you haven't already. It also could be java. You might try killing that too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.