0

I actually messed up with my original administrator account which is . The problem was the unity won't start properly. It's just that, it only shows the background and some few icons on the top bar and nothing else.

I decided to create a new user and assign administrative privilege to it . So now, I thought I could just access the home directory of , since all of my files are there, but then I'm not permitted. I thought, I could just change the ownership and shipt it over to , so that's what I did. I tried to chown home directory to be the ownership of . I thought, that was all okay. After I restart, and was very expecting that I could easily access the home directory of , I was surprised that the files and folders are gone? As I've checked on the terminal it is being unmounted.

From the README, it said to use the ecryptfs-mount-private but every time I do, it's not working :(

From user , I tried to sudo su And then, go inside the home directory of , and entered ecryptfs-mount-private ERROR: Encrypted private directory is not setup properly

I really need to get my files :( .. what should I do? any advice?

0

The easiest way to get a hold of your files is to boot into your LiveCD and copy your old /home directory to your new /home directory. By using the LiveCD, you totally bypass the operating system's protection. Just be careful you don't mess around too much, as you won't get any warnings. Good luck!

  • Hi, thank you for your response. I really appreciate it. I think, your suggestion is rightful answer, but though I can afford to wait more time just to get a copy of the live cd, therefore I took a gamble on changing again the ownership of the files inside .Private directory. It actually work! :) – Teody C. Seguin Nov 17 '13 at 1:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.