I am new to Ubuntu and using a Dell Latitude XT2. When Installed Ubuntu there was a problem with my wireless drivers. After looking around a bit I managed to fix it with the following commands:

sudo apt-get purge bcmwl-kernel-source && sudo apt-get install firmware-b43-installer


sudo apt-get install bcmwl-kernel-source

with a wired internet connection.

My touchscreen was also causing me problems so I tried to turn it off with:

xinput set-prop 'N-Trig MultiTouch' 'Device Enabled' 0

which again works.

My problem is everything reverts when I turn my laptop off so I am currently having to do this every time I turn it on. Is there anyway to fix this?

  • Could you provide the output of lspci -knn | grep -A2 Net command? – numand Nov 16 '13 at 19:24
  • Sure, its: '00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM Gigabit Network Connection [8086:10f5] (rev 03) Subsystem: Dell Device [1028:0252] Kernel driver in use: e1000e -- 0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01) Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c] Kernel driver in use: wl' – WireInTheGhost Nov 16 '13 at 20:20
  • I do not have any idea about your problem with touchscreen, sorry. But, I think it is better to ask touchscreen problem in a separate question. – numand Nov 16 '13 at 21:40

According to Ubuntu bcm43xx documentation you should install firmware-b43-lpphy-installer package and use b43 module. So, first thing to do is to remove firmware-b43-installer and bcmwl-kernel-source packages. For this, give

sudo apt-get remove --purge bcmwl-kernel-source firmware-b43-installer

command. Then give

sudo apt-get install firmware-b43-lpphy-installer

command. After installing the pacakges, load b43 module by

sudo modprobe b43

command and you wireless card should work. If it does not work after rebooting computer, try to find out whether b43 module is blacklisted or not by looking files in /etc/modprobe.d/ folder. You can try

grep b43 /etc/modprobe.d/*

command. If the output is similar to

/etc/modprobe.d/blacklist.conf:blacklist b43

, open that file

sudo -H gedit /etc/modprobe.d/file_name

and remove blacklist b43 line.

  • Thanks, i already tried the first three steps. I have done them again and they didnt work. The output i get from grep b43 /etc/modprobe.d/* is /etc/modprobe.d/blacklist.conf:# replaced by b43 and ssb. /etc/modprobe.d/blacklist.conf:blacklist b43 So i opened the file you mentioned to remove the line you suggested but the file is empty. – WireInTheGhost Nov 16 '13 at 23:14
  • File's being empty is strange. Are you sure that you opened the /etc/modprobe.d/blacklist.conf file? – numand Nov 16 '13 at 23:16
  • Sorry, I realised that I forgot to remove firmware-b43-installer package, so I updated my answer. – numand Nov 16 '13 at 23:54
  • The output I am getting from grep b43 /etc/modprobe.d/* is now: /etc/modprobe.d/blacklist-bcm43.conf~:blacklist b43 /etc/modprobe.d/blacklist-bcm43.conf~:blacklist b43legacy /etc/modprobe.d/blacklist.conf~:# replaced by b43 and ssb. so i am entering this:sudo -H gedit /etc/modprobe.d/blacklist-bcm43.conf but its empty. The /etc/modprobe.d/blacklist.conf isnt empty so i deleted the line you said and nothing has happened. – WireInTheGhost Nov 17 '13 at 11:45
  • Seems to be working now. Thanks a lot for your help! – WireInTheGhost Nov 17 '13 at 16:12

For people with the same touchsceen problem you can quickly create a start up program to disable the touchscreen each time you log in: Open terminal and type:

gedit notouch

then put:

xinput set-prop 'N-Trig MultiTouch' 'Device Enabled' 0

into the text file and save it.

back in the terminal type:

chmod 744 notouch

Then navigate to your start up applications (Search Startup Applications in your dash) and add:

Name: Touch Off
Command: /home/username/notouch
Comment: Turns off touch

This will then run each time you startup you computer and disable the touchscreen.

For original answer (where i found it) see here: http://ubuntuforums.org/showthread.php?t=1600818&page=2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.