I just installed Ubuntu 13.10. I went to the Google Chrome website using default Firefox, downloaded 64 bit chrome, went through the process of the software center, and opened Chrome.

However, every time I open the Google Chrome icon on the Launcher, it just glows yellow while a different icon called Google Accounts - Google Chrome opens.

How do I get rid of this Google Accounts icon and just let the original Google Chrome open ?

Executing gedit google-chrome.desktop in /usr/share/applications yielded:

*(gedit:2454): WARNING**: Could not load Gedit repository : Typelib fil for namespace 'GTKsource' version 3.0 not found. 

When I executed gedit google-chrome.desktop in Terminal, the gedit page was empty (it did not display any contents for the google-chrome.desktop file).

How to fix these ?

EDIT 2: Executing google-chrome from terminal opens the regular Google Chrome, but it runs from terminal (meaning that if I end the Terminal session, I end the Chrome session as well).

  • do ls /usr/share/applications. Find the google-chrome.desktop, or something related to google chrome. Open the terminal and type gedit ThatName.desktop and post the contents of that file here. – nitishch Nov 16 '13 at 9:39
  • Hello There! I did what you said to do and this is what I got:*(gedit:2454): WARNING**: Could not load Gedit repository : Typelib fil for namespace 'GTKsource' version 3.0 not found. When I did Getid google-chrome.desktop, the gedit page was empty. I tried again and I got the same message but the only thing that changed was (gedit:3289) the second time around. – ubuntutest Nov 16 '13 at 22:07
  • 1
    what was the output of ls /usr/share/applications? Does it contain google chrome related file? – nitishch Nov 17 '13 at 5:24
  • Yes, there is a file called "google-chome.desktop" in the list when I execute that command. – ubuntutest Nov 17 '13 at 5:38
  • Open that file and add the contents of file in your question. I am not sure if the problem is really in that file, but I guess it is. And also try google-chrome in terminal and tell us what happens. – nitishch Nov 17 '13 at 6:47

In Terminal run :

gksudo gedit /usr/share/applications/google-chrome.desktop

If the resulting Gedit is empty, add following lines to it (Copy and Paste):

If it is not empty, edit the available content in it to become as following:

[Desktop Entry]
Name=Google Chrome
GenericName=Web Browser
Exec=google-chrome %F

[Desktop Action NewWindow]
Name=Open a New Window

[Desktop Action Incognito]
Name=Open a New Window in incognito mode
Exec=google-chrome --incognito

[Desktop Action TempProfile]
Name=Open a New Window with a temporary profile
Exec=google-chrome --temp-profile
  • Thank you for the answer. Could you please explain what it does? And did you just take the text from your Gedit file for Google Chrome? – ubuntutest Nov 17 '13 at 9:05
  • Thank you again, it worked. However I do have some questions: For one, what does changing from %U to %F do? Secondly, I got this message twice when I closed the Gedit window after I edited the file: (gedit:3381): GtK -WARNING**: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files – ubuntutest Nov 17 '13 at 9:41
  • First thing, to change or write in system files you have to gain root previlege. To gain it you need to add gksudo infront the gedit command. when %U is used, only that user account can open the application. Sometimes there are situations even I did install the application, Ubuntu take it as root account and doesnt give me the chance to open it. This happens when there is only one user account there. When %F is used, any user can use this. So what I do is change it to %F. – user224082 Nov 17 '13 at 10:20
  • Thank you for the explanation. If I am the only user on the machine, should I change it back to %U? And could you please explain what the error message I received means? – ubuntutest Nov 17 '13 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.