I'm installing Ubuntu 13.10 Server (amd64) on a HP Proliant Microserver. I'm using a USB keyboard which works fine until I opt to install Ubuntu and get to the (first) "Select a language" screen. At this point the keyboard becomes unresponsive and the number lock light turns off.

The BIOS is configured to support USB devices in legacy mode (hence I can get past the initial boot screen). Unfortunately the machine does not have a PS/2 port, however I have tried using a range of keyboards to debug this:

  • a standard USB keyboard (Microsoft Ergonomic 4000)
  • an alternative USB keyboard (G15)
  • a PS/2 keyboard using a passive PS/2-USB connector
  • and another PS/2 keyboard using an active PS/2-USB connector.

Unfortunately I get the same results with all of these. I note that this has happened to someone else with a wireless keyboard - could this be a case where the installer is not reloading USB devices?

  • You mean the first (pre-boot) language selection or the text installer one? Have you tried just replugging the keyboard? – Braiam Nov 16 '13 at 0:52
  • The text installer (I can select a language and start the install from the first menu, it stops working at the second). I did try that but it didn't seem to work. Might try that with the PS2 keyboards just in case. – Ross Nov 16 '13 at 15:17
  • MM.... it could be also the disk with defects, have you tried another disk? – Braiam Nov 16 '13 at 15:25
  • The md5 of the ISO checks out, however I'm installing from a USB so I'll have a look to see if the iso->img->usb worked properly. I'm sure I've installed Debian on this machine before so that could be it :) – Ross Nov 16 '13 at 15:37
  • I think that if it's reproducible like that, you have a bug in the ubuntu version of the debian-installer. It might be useful to report it (through ps/2 is old...) – Braiam Jan 5 '14 at 22:56

I found that unplugging the kb and then inserting it into a different usb port did the trick.


I experienced the same problem. Turns out there was something in the BIOs setting that needed to be enabled.

This is how I found it:

  1. Press f2 on Boot to enter BIOs setting
  2. When in BIOs, Change Boot order to desired preference (CDboot first)
  3. Go to Advance << Chipset Config << USB Device Legacy Support (enable this)
  4. Save and Exit

Althouggh every device may be different, the Idea is to look for some setting involving USB devices and ensure that they are enabled during'Legacy' mode.

Hope this helps.

  • On Asus Z87i-Deluxe, installing Ubuntu Server 16.04, I just found out that setting USB Device Legacy Support to Smart auto in BIOS was insufficient; I had to set it to Enabled (didn't try to see whether Auto would work or not). Nevertheless, this answer put me on the right path (the others--namely dis&re-connecting the KB to a USB3 port--didn't work). – Jonathan Y. Apr 21 '16 at 12:44

I just ran across the same problem and have found no fix -- I don't have a PS2 KB handy.

The only way I got around it was to load 13.04 and then run the do-release-upgrade.

So far I've had to do this 6 times on different servers. On the later installs I've run apt-get update & apt-get upgrade prior to upgrading the OS. I'm not sure if there's a benefit but at least I know that everything was current before upgrading the OS. I haven't noticed a difference between the servers.

It is not a disk with defects or anything like that. Seems to be an issue with a USB KB.


I used and USB Hub and the KB picked up and we could continue with the install. Not sure what causes this but it worked for me.


I have noticed that this is a conflict on newer motherboards with USB 3. If you unplug the USB port, and plug it into a USB 3 port, it'll register. At least, it did for me. There must be a conflict between USB 3 and USB 2 ports handling keyboards in 13.10.

  • Dunno why this have been downvoted, it worked for me. – rkrahl Jan 15 '15 at 11:19

In my case it was swap out a Logitech wireless keyboard for a more conventional hardwire USB keyboard. The Logitech usually works fine but once it gets to the language page it freezes up.

Also had bad USB key install media so ... that probably does not help matters.

Not the answer you're looking for? Browse other questions tagged or ask your own question.