3

I installed Gnome 3.10 on Ubuntu 13.10. Just to try it. Later I decided to remove it and go beck to Unity. It took me a while to remove Gnome. After that I experience some issues:

  1. in some apps global menu items are greyed out (all the menu item in Gimp, messaging indicator items, ...) I cannot click any of these items, but keyboard shortcut is working (for example - cannot click "Save" but CTRL+S works)

  2. I have two network indicators in unity panel

  3. in session menu there is a red circle in front of my username

Any ideas...???

2

I'm having the same problem, but I did not go through the installing/uninstalling GNOME 3.10. I think it just came with the regular ubuntu update. This unity-panel/global menu is such a headache, I don't know why the can't get it right.

Anyway, this works for me for GIMP: * open a terminal and run: $ killall -HUP unity-panel-service

This will reset the menu and the greyed out items will then be available. However when you start GIMP again, it's back to the greyed out menus, thus you need to killall again.

Hope this helps -H

  • I couldn't fix it, so I did clean install of Ubuntu and installed all updates... Now it works fine... I don't know what was the problem... – Daniel Nov 18 '13 at 12:30
2

I just actually upgraded to ubuntu 13.10 and got exactly the same problem. The appmenu is actually having a bug.

So to fix the problem (workaround) I actually disabled the app menu.

Run your application evolution using :

UBUNTU_MENUPROXY=0 evolution

The menu will be inside the application and not in the appmenu. Items will not be greyed out anymore.

Hope this help.

1

Even if the menu entries are grayed out, I can still access them through the Unity HUD (press ALT).

1

This is a bug triggered with the addition of the libgtk-3-0 package from the Gnome-PPA. The easier way to solve is to remove the PPA and downgrade the package.

Important comments from the bug reports:

0

This worked for me in OpenOffice:

sudo killall -HUP unity-panel-service

Thanks

-1

Same problem for me and I found a solution (LibreOffice is concerned too):

sudo apt-get remove indicator-appmenu

Source : https://bugs.launchpad.net/ubuntu/+source/unity-gtk-module/+bug/1263205

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.