1

I have Xubuntu 13.10 running on a Lenovo T520 laptop. Everything worked just fine, but today, when I was in the middle of a Skype call, my laptop just disconnected from Wi-Fi. And now it says Wi-Fi is disabled by hardware switch in the networking menu.

I tried rfkill unblock all, but with no effect: rfkill list all still says:

phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

The Wi-Fi switch hotkey (Fn+F5) doesn't have any effect as well. Also I tried pressing Fn+F5 while booting the system but with no effect. I noticed that the Wi-Fi indicator LED below the screen is now always off, even on system reboot.

Can this mean that my Wi-Fi controller is damaged?

3

Maybe, the wireless switch got turned off. You can see the location of the switch here. It's component #7.

0

Try those commands:

  1. sudo rfkill unblock all

  2. rmmod ath5k && modprobe ath5k

  3. rm /dev/rfkill

  4. sudo iwconfig wlan0 txpower auto

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.