2

I am trying to install Emacs 24 on Ubuntu 12.04 from the PPA as follows

sudo add-apt-repository ppa:cassou/emacs
sudo apt-get update
sudo apt-get install emacs24 emacs24-el emacs24-common-non-dfsg

My system is already running Emacs 23.3.1 from the default repositories. The install runs normally before erroring out with the following message.

install/ilisp: Handling install for emacsen flavor emacs24
emacs-install: /usr/lib/emacsen-common/packages/install/ilisp emacs24 emacs23 failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 20.
dpkg: error processing emacs24 (--configure):
subprocess installed post-installation script returned error exit status 255
Errors were encountered while processing:
 emacs24
E: Sub-process /usr/bin/dpkg returned an error code (1)

I came across this thread which also discusses a broken Emacs 24 installation but their problem was of missing files, which mine does not seem to be. I have also made sure that the dependencies are there by running

sudo apt-get install build-essential
sudo apt-get build-dep emacs

This thread from last year about 11.10 recommends removing all of emacs first but that sounds pretty extreme, and as one commenter there pointed out, purging emacs from 12.04 may remove some Ubuntu components as well. I am hoping there are some better solutions out there by now.

1

It seems like you have a package (ilisp) in your distribution that is having problems upgrading, and that makes the whole upgrade to fail. Every file in your directory /usr/lib/emacsen-common/packages/install will be executed with emacs versions (new and old) as arguments as part of the upgrade process. If one of them fails, the upgrade will fail.

You have two options here:

  1. Debug the script ilisp at that location, find out why fails and workaround it.

  2. Remove the script (or store it somewhere else) so that the upgrade does not fail. This is the easiest solution, but a little risky (you always can take a look to the script to know what you would be missing).

  • 1
    Thanks. I opted for Option 2 (removed ilisp) and reran the installation. Everything turned out to already be at the newest version. It seems ilisp was the last step in the installation which had otherwise completed successfully. – wsaleem Nov 18 '13 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.