I've updated my system, the system boots but I never get to the graphic interface. It seems to hang.

I get a black screen, at the end of the screen, I got my cursor _ blinking and I don't know what to do.

I believe the system is OK somehow, because I notice the screen saver activation after a while but nothing more. If I press any key, the screen savers vanishes but I just don't know how to leave from this state.

I've tried Ctrl + C, entering exit but I just get the letters there, nothing happens.

At the end, my /var/log/Xorg.0.log has:

DRI Initialization failed kernel module (fglrx.ko) may be missing or incompatible 2D and 3D acceleration disabked

glesx __g1ESXExtensionInit: No GL ES2.0 Capable screen found!

Caught signal 11 (Segmentation fault). Server Aborting Please consult the X.org Foundadion Support (EE) fglrx(0): fireg1_SetSuspendeResumeState FAILED -9

ddxSigGiveUp: closing log


I've done:

sudo apt-get remove --purge fglrx

after which I've rebooted. Now I got nothing on my screen. Not even the command line.

What can I do? How can I fix this problem?

  • 1
    The udev message is almost certainly a dead end. udev spews out all sorts of stuff on perfectly working machines. Same with ureadahead. The content of ~/.xsession-errors and /var/log/Xorg.0.log would be helpful. – Oli Apr 28 '11 at 23:26
  • @Oli - I've just searched and if I do alt+f2 I get the possibility to login. I have done that. But I don't know what to do more then this. :(( – MEM Apr 28 '11 at 23:31
  • How can I see those lines. I tried vim filename . but I haven't installed and when I do apt-get I got some mirror errors. I've tried gnome-open filename but I get some errors as well... how can I see those files? – MEM Apr 28 '11 at 23:41
  • nano should be installed by default and is a fairly good editor. Failing that less <filename> should show you the file. – Oli Apr 28 '11 at 23:50
  • Oli I'm seeing the first file. It's to big. I have no clue how to paste it here. Perhaps the end of te file corresponds to something ? – MEM Apr 28 '11 at 23:58

You shouldn't have purged flgrx, really.

I experienced exactly same problem after updating to 11.04 (booted fine with old kernel 2.6.35, but trying to boot with default kernel of 11.04 I had blank screen and blinking cursor)
All I had to do is add radeon.modeset=0 to grub options (along with quiet splash) once you can add this option pressing E in grub menu for permanently editing and updating grub.

If anything, you can edit grub options doing

gksudo gedit /etc/default/grub

The line will look like something ... ="radeon.modeset=0 quiet splash".

Save the grub file then update the grub config using sudo update-grub.

| improve this answer | |

It's a bug: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/761830

It hasn't been fixed yet, but don't despair. When you get to that black screen with the blinking cursor, you are stuck at tty7, which doesn't exist. Hit Ctrl + Alt + F1 to take you to tty1 (terminal one) where you can log in as normal. This was partially fixed from an earlier bug report so that ordinary desktop and server installations don't get this, but command line installations still do. From the topic of this thread, it apparently can happen on certain upgrades too.

I haven't found a workaround for it that I like, (editing the grub2 config files), so I just do Ctrl + Alt + F1 and will keep doing so until the patch for grub2 comes through. (I have a command line virtual machine and haven't upgraded my host yet. Just as well)

Your upgrade probably went fine, your files are probably fine, we just have this annoying bug in grub2 that doesn't let us boot to the proper interface. Yet. I'm going to wait it out rather than tinker, because everything works just great when I get past it!

| improve this answer | |

I just upgraded two machines, and they are both seriously mucho deado. These two are ThinkPads, one is older under the IBM logo, while the second one is Lenovo branded. I was hoping to find some hint to proceed, but I'm obviously a fool for hoping that Ubuntu was not going to get worse this time around. I actually succeeded on an even older machine, but apparently because it rejected Unity completely.

Well, at least I'm not a perfect fool. I had already stopped relying on Ubuntu, and the two new deaders are actually only VMware Player emulators, though on two different machines.

In conclusion, I've been using Ubuntu for about 5 years now, and it peaked several years ago. To me it seems obvious that their financial model is fatally flawed, so just for grins, I thought of a better one. Here's the link in case you might find it amusing.


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.