I went back to my desktop after a bunch of months not using it, and I decided to upgrade Ubuntu to the newest version (I was still in 12.04). I had to download a driver for my TP-Link USB wireless device (TL-WN725N, chip RTL8188eu), which worked flawlessly in 12.04, then stopped working after the upgrade to 12.10. I recompiled the driver and it worked again (My router is pretty far from my room so I can't really use an ethernet cable without moving it).

Then problems started! After upgrading to 13.04, it gives me an error when I try to run it. I looked on google and found many solutions, but always with the RTL8188CUS chip, which isn't using the same driver as mine... So I'm kinda stuck! I could plug it to upgrade to 13.10, but I have no idea if my driver will work better on this version.

Any solution? I would paste the error, but I'm at work currently. I'll add it later when I'm home, if needed to fix the problem!

Thanks! I love Ubuntu, hope I'll find a way to make it compatible with my wireless! :)

  • Why did you NOT attempt to upgrade directly to 14.04 LTS, from 12.04? You will have issues under 12.10, 13.04 or 13.10 that are not possible to address. All three are now end-of-life. I would personally recommend a new / clean install of 14.04.2 LTS. – david6 May 4 '15 at 7:14

If you are quite certain that it's an RTL8188eu chip, then I suggest this package: https://github.com/lwfinger/rtl8188eu/archive/master.zip Right-click the zip file and select 'Extract Here.' Then, in a terminal:

cd rtl8188eu-master
sudo make install
sudo modprobe 8188eu

If you are unsure if it's an RTL8188eu chip, please post:


The file I linked above 'makes' perfectly on my 13.10 system.

| improve this answer | |
  • 1
    Thanks a lot for the quick reply. I am 99% confident it's the 8188eu chip, but I'll look and post the lsusb infos here as soon as I am home. I'll also try your solution later, the driver I downloaded wasn't the same. – JFD.Lag Nov 15 '13 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.