0

I'm using Ubuntu 12.04 (Precise Pangolin) and am trying to disable the Alt + F1 shortcut as I need it for usage in Pycharm. I have already gone through How can I disable the Alt+F1 / Alt+F2 shortcuts?. But it is not working for me. What am I doing wrong?

The steps I have followed to disable Alt + F1:

  1. I modified in dconf using the following command:

    gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "[]"
    
  2. Logged out and logged in. Still Alt + F1 sends the keyboard focus to the Unity panel.

  3. Restarted the machine. Still Alt + F1 sends the keyboard focus to the Unity panel.
  4. Also verified that the configuration is still set using the following command

    gsettings get org.gnome.desktop.wm.keybindings panel-main-menu<br><br>*Output*<br>@as []
    

Environment: Ubuntu 12.04.3 LTS. And I don't remember switching to Unity 2D. But I think I'm using Unity 2D from this question.

1
0

I have the same problem in "Unity 2D" mode in the logon screen (metacity + unity-2d-shell). I tried all "known" stuff (gconf + dconf + gsettings) - it doesn't help.

But if switching to "Unity" mode in the logon screen (compiz + unity-shell) and tweaking in compizconfig-settings-manager- everything works fine!

So if you don't mind switching to "Unity" - then you will be fine :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.