22

I dont know how to install Resynthesizer in gimp.I want Resynthesizer for editing my images.Anyone please help

27

For GIMP <= 2.8 the "Resynthesizer" plugin together with other scripts and tools (including the brilliant tool "Heal Selection") can easily be installed with the package gimp-plugin-registry

From the shell:

sudo apt-get install gimp-plugin-registry

For Gimp >= 2.10 the plugin-registry and with it the resynthesizer and heal-selection plugins may not (yet) be available. Until we have access to these tools again we need to put the plugins

  • resynthesizer
  • resynthesizer_gui
  • plugin-heal-selection.py

to any of the defined plugin folders. I recommend ~/.config/GIMP/2.10/plug-ins in our HOME.

We can get these either from compiling the source from the project's home page or from downloading an Ubuntu DEB file a release of the plugin-registry for GIMP 2.8 matching our architecture to extract above files. I tested these to still work on GIMP 2.10.6.

5
  • No longer included in the package as of May 09 '14; at least not in version 3.5.4-1 for Ubuntu 12.04. Hope this saves other users some time. May 9 '14 at 11:35
  • 2
    Still there in later releases. You may have to upgrade Gimp to 2.8 to get it working then. See askubuntu.com/questions/134035/…
    – Takkat
    May 9 '14 at 11:45
  • This no longer seems to work in GIMP 2.8 on Ubuntu 18. This package does not contain the Resynthesizer plugin.
    – Cerin
    Jan 22 '20 at 19:12
  • @Cerin: sorry to hear you have issues. Resynthesizer and heal selection are still provided with the default gimp-plugin-registry package for 18.04 (see here for a list). Did you add a ppa for these packages? You may have to install it manually, as outlined above.
    – Takkat
    Jan 22 '20 at 20:55
  • @Takkat I was incorrect. I initially tried to install the precompiled version linked from the github repo, but for some reason that's a 32-bit version that doesn't work on any modern 64-bit system. However, if that's installed, it also prevents the package from working, since the ~/.gimp-2.8/plug-ins directory overrides the package's. Once I deleted my local plug-ins folder, then the package plugins worked.
    – Cerin
    Jan 23 '20 at 3:53
4

In case anyone used flatpak to install the lateset GIMP (2.10.20 as of this writing), I ran the command flatpak search org.gimp.GIMP and noticed the following package available:

org.gimp.GIMP.Plugin.Resynthesizer

Seeing that, I ran flatpak install org.gimp.GIMP.Plugin.Resynthesizer, opened up GIMP, and the new filters were available and worked as expected.

you can also search for all plugins avalible to install using flatpak:

flatpak search org.gimp.GIMP.plugin
3
  • 1
    flatpak search GIMP No matches found Sep 13 '20 at 13:41
  • Worked! You saved my day. Apr 7 '21 at 16:42
  • That plugin got integrated only when i installed the latter option of the available packatge runtimes i.e. version x86_64/2-40
    – polendina
    yesterday
1

Here is a link: https://web.archive.org/web/20180225174428/http://registry.gimp.org/node/27986

Basically you download the file and extract it, after that you copy it into your gimp plug-ins folder.

Folder location: Go to your home folder, press Ctrl+h, search for .gimp2.x folder (x is number of your gimp version) then search for plug-ins folder.

3
  • Is the link still alive? I can't reach anything by this address...
    – dKab
    Oct 1 '18 at 18:11
  • 1
    link is dead. Please see the git repo. There are instructions on how to get things working.
    – ivan92
    Oct 4 '18 at 9:08
  • "The registry is dead!" Please update your answer. Don't simply add a comment. You're allowed to edit your own answers. Also, the git instructions don't work either.
    – Cerin
    Jan 22 '20 at 19:13
0

For me this worked - flatpak install flathub org.gimp.GIMP.Plugin.Resynthesizer

1
  • did not work for me till i added the flathub - not sure why; so how is this a duplicate?
    – vkt
    Oct 4 '21 at 10:59
0

Got it worked by following, https://askubuntu.com/a/377330/1384856 (Gimp - 2.10.28)

Make sure the folder plugins are copied to, is configured in Gimp. Check: Edit > Preferences > Folders > Plug-ins

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.