1

I have searched here and the web and many other people have similar issues going back a few years (https://askubuntu.com/questions/319565/my-google-account-not-working-properly-with-ubuntu for example), but no one seems to have fixed it. I get the same results in Chrome, Firefox and Epiphany browsers. Have done complete removal's and re-installs of them all and Ubuntu. I originally had this problem in Mint, but re-installed Ubuntu, same problem

I have this problem on 3 Ubuntu machines, 2 on 13.10 (fresh installs, not upgrades) and one on 11.10, the 11.10 dualboots windows 7 and that is what I am using now. Only in windows can I log on to any Openid site, and only on windows can I use all Google services with out problems. Dropbox client in Ubuntu can not connect, windows can.

So Openid and Google search results time out, in firefox I get the 408 error, in chrome the oops message. But I can log into Gmail without problems in both browsers.

With all of them the problem started with a change of service from my ISP (worldnet.co.nz when I moved from adsl to fiber optic or UFB). Speed tests using speedtest.net produce similar download speed, but the Ubuntu machines are unable to do the upload tests, it just sits on 0.00 for as long as I can wait.

One of the machines is a laptop and it works fine when I take it else where and use other networks. So this would appear to be a network issue, but after 2 weeks my ISP can find nothing wrong, and have completely removed any firewall protection from my connection. My main desktop is in the DMZ zone for my router, I have a static IP address, and no fire wall running on it at present.

Windows 7 works correctly which suggests my ISP is correct when they say it's not a problem at their end. My router does not support IPv6 and I have disabled IPv6 in one of the machines, no change. Ubuntu updates work fine, I have no problems with apt-get. I can browse all generic web sites like www.nzherald.co.nz or askubuntu, but I can't log into some sites.

I have tried changing dns servers, no difference, and nslookup and dig return the expected results always. traceroute works fine.

Can any one help here?

I have installed dnsmasq. unistalled it, tried static ip, dhcp (my router is assigned static ip by my isp which changed with the new fiber connection). Tried Google dns, my isp dns manually added, auto assigned dns.

ifconfig reports a virbr0 interface on 192.168.122.1, the rest of the machines on my router are on 192.168.0.* and I do not know where this virbr0 comes from. Gnome boxes maybe? All machines on the router can see each-other in files folders.

So to recap, a fresh wipe all data re-install does not fix it, booting of the Ubuntu 13.10 live usb shows the same problems. Windows has no problems.

Please help me, as bizarrely this seems to be a problem with Ubuntu only.

Thanks,

marked as duplicate by Alvar, jrg Jan 2 '14 at 2:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Yes. Different symptoms but the same problem or at least the same solution fixed all the problems. One question remains, how solve this? I stumbled on the solution after several weeks of trying different searches in Google. I asked many questions, and came across many similar questions asked by other people. There didn't seem to be anything to point to a problem with Linux's MTU settings. A windows PC on the same router is working fine with the MTU set to 1500, after fine tuning the 2 Linux machines will not work with an MTU set higher than 1468. – Rob Nov 24 '13 at 17:15
1

Ok, I finally solved the problem using plain old dumb luck and persistence.

I have lost the link, but via many searches I came on a path to a Russian web site (translated to English by Google) where people had similar problems with a range of TP-Link routers, the same brand as my ISP provided to me.

The solution was to lower the MTU from it's default 1500 to 1400. Maybe higher will work, but for today I am a believer in "Don't fix what isn't broken"

I hope this helps some one else :-)

Not the answer you're looking for? Browse other questions tagged or ask your own question.