98

Upon trying to make a startup disk (USB) for Ubuntu 12.04, the system prevented boot loader installation. I'm getting message:

Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)

Can I still use the startup disk?

3
  • The disk tool also allows you to easily encrypt a partition. Something gparted doesnt do as far as I can tell. This bug is causing features to be missing. – user295470 Jun 20 '14 at 22:16
  • Probably you cannot still use the startup disk. It doesn't sound like it was made properly. I had similar issues. You may find this helpful: askubuntu.com/questions/471579/… – Elder Geek Jul 15 '14 at 22:33
  • Delete the partitions on usb using a tool such as fdisk then try again. – Tim Jonas May 28 '16 at 16:02
84

This has been reported as a bug. But you can try this work around and see if it works. Install Gparted if you don't have it installed. If its not, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install gparted

Once installed, open the application, and before formatting, make sure that you choose the right drive, and Unmount the disk by right clicking on the partition, and choose Unmount, then you can use the format To option, to format it to whatever type of file system you wish. Once done click on the green check mark to apply the changes.

enter image description here

12
  • Unmount option displayed an error message: "Input/output error during read on /dev/sdc". How shall I proceed now? – Ramvignesh Aug 18 '14 at 0:38
  • What's the output of:sudo fdisk -l /dev/sdc? – Mitch Aug 18 '14 at 5:13
  • 2
    Try running sudo dd if=/dev/zero of=/dev/sdc and let me know. – Mitch Aug 19 '14 at 5:17
  • 1
    I was getting this error Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0) it worked, thanks :) – vipin8169 Sep 16 '14 at 6:39
  • 1
    This bug is still present in 18.04 LTS – Ini Dec 8 '18 at 19:21
2

A weird solution that worked for me where GParted did not, was to format it using Mac OS X's Disk Utility initially (not the file system I ultimately wanted). Then I was able to format it on Ubuntu to NTFS which is what I wanted, and didn't encounter any timeout.

1
  • 1
    Cool.... What I did was that as it was startup disk, by going into disks removed the partition and freed all space then formatted to NTFS format which released the storage and the again format to FAT. – kshitij Dec 24 '20 at 10:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.