2

Since the upgrade to Kubuntu 13.10 today I lost the borders around maximized windows. How can I re-enable them? I tried this and of course changed true to false, but it doesn't work.

1
  • As I understand it, there are two separate options here. BorderlessMaximizedWindows=true causes the title bar and borders to not be shown for maximized windows. Setting this to false is not what causes borders to be shown for full screen windows. MoveResizeMaximizedWindows=true causes the borders to be shown on maximized windows so that they can be resized by dragging the borders. This option was removed from kwin in KDE 4.11 and has been reimplemented as a part of the oxygen window decoration for KDE 4.12.
    – david
    Dec 5, 2013 at 15:57

1 Answer 1

2

The ability to show borders on maximized windows was removed from kwin in KDE 4.11. You can find more information about this decision in bug 299245. Basically, the implementation was a hack that caused multiple bugs, and the developer said that the proper place for this feature was in the decoration rather than in kwin.

So, this feature was added to the oxygen window decoration. Unfortunately, this change has not made it into a stable KDE release yet. Once released, the option will be available by going to System Settings->Workspace Appearance. Then, if you're using the oxygen decoration, you'll be able to click on the 'Configure Decoration' button, go to the 'Fine Tuning' tab, and check 'Display window borders for maximized windows'.

3
  • I prefer 'Plastik' above 'Oxygen'. I did find a reference to a script to replace the functionality, but it doesn't seem to be finalized yet. Nor do I have any clue how to install and test it anyway.
    – jippie
    Dec 4, 2013 at 23:12
  • Is it me, but currently (using KDE Plasma 5 and Breeze) the title bar is shown by default when maximized and there is no option to hide it... Is this the other way around? May 20, 2015 at 17:28
  • jippie was talking about just the resize borders, rather than the title bar and the borders. The BorderlessMaximizedWindows setting removes the title bar and borders, and it defaults to false. The other setting to show resize borders for maximized windows has been removed from kwin and added to the oxygen decoration.
    – david
    May 22, 2015 at 17:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .